Bug 1253810 - aws instance retirement has a state of powering_down not powered_off
aws instance retirement has a state of powering_down not powered_off
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.4.0
Unspecified Unspecified
high Severity medium
: GA
: 5.6.0
Assigned To: mkanoor
Kyrylo Zvyagintsev
ec2:retirement
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-14 14:51 EDT by Josh Carter
Modified: 2016-06-21 13:27 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-21 13:27:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1555683 None None None Never

  None (edit)
Description Josh Carter 2015-08-14 14:51:23 EDT
Description of problem:

Retiring a aws instance fails to update the instance's power state once it has fully powered off. 

Last long message concerning power state shows 

[----] I, [2015-08-14T14:39:45.215222 #3969:afbea0]  INFO -- : <AutomationEngine> <AEMethod [/ManageIQ/Cloud/VM/Retirement/StateMachines/Methods/amazon_
check_pre_retirement]> Starting
[----] I, [2015-08-14T14:39:45.547303 #3969:8b18de0]  INFO -- : <AutomationEngine> <AEMethod amazon_check_pre_retirement> Instance:<last-test> on EMS:<g
ss-aws has Power State:<powering_down>
[----] I, [2015-08-14T14:39:45.559813 #3969:afbea0]  INFO -- : <AutomationEngine> <AEMethod [/ManageIQ/Cloud/VM/Retirement/StateMachines/Methods/amazon_
check_pre_retirement]> Ending


AWS Console shows the instance as being stopped. CloudForms UI stays in the powering_down


Version-Release number of selected component (if applicable): 5.4.1


How reproducible:
very

Steps to Reproduce:
1. retire a aws instance with cfme
2.
3.

Actual results:


Expected results:


Additional info:
Comment 3 mkanoor 2015-08-31 16:59:58 EDT
Please send steps to reproduce.
We normalize the power states across cloud providers so we might not match 1-1 with EC2.
The retirement takes a while and depends on if it is a EBS instance or a regular instance. They take different paths according to Amazon
http://docs.aws.amazon.com/AWSEC2/latest/UserGuide/ec2-instance-lifecycle.html#lifecycle-differences
Comment 4 mkanoor 2015-11-02 14:30:48 EST
Any updates on this ticket, can we close it
Comment 5 Josh Carter 2015-11-02 14:37:01 EST
Hi, 

The power state shows powering_down until the next major ems refresh occurs for aws. The instance displayed that it was powered off in the aws console within seconds of the retirement state machine executing. It seems like we need to perform a ems refresh at the very end of the retirement state machine for amazon
instead of leaving it in the "powering down" mode. Users will have to wait until the next generic timed refresh to occur or manually kick off a refresh just to have correct power state information. 

This is pretty easy to see by monitoring both the aws console and retiring a given aws instance.
Comment 6 mkanoor 2015-11-05 14:17:44 EST
Can't recreate this.
Could they be using the old retirement state machine
Comment 7 Josh Carter 2016-06-21 13:27:45 EDT
Madhu, 

I think this bz was due to aws config not configured correctly. 

Going to close the bz.

Note You need to log in before you can comment on or make changes to this bug.