Bug 1253888 - System doesn't recognize sound card anymore after uninstalling the pulseaudio-equalizer package
System doesn't recognize sound card anymore after uninstalling the pulseaudio...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: pulseaudio-equalizer (Show other bugs)
22
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Jaromír Cápík
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-14 22:57 EDT by Martín Cigorraga
Modified: 2016-01-31 21:01 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-19 12:23:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martín Cigorraga 2015-08-14 22:57:08 EDT
Description of problem:
SW: up-to-date Fedora 22 GNOME edition.
HW: mid-2010 HP Pavilion laptop.

I installed this PulseAudio addon in order to bring a system-wide equalizer, however because the sound quality was very choppy later I decided to uninstall it. Problem is that after uninstalling the package the sound card (built-in) isn't recognized anymore. I had to reinstall the package in order to get the system recognize it again.

Version-Release number of selected component (if applicable):
2.7 / 16.fc22

How reproducible:
Always.

Steps to Reproduce:
1. Install the pulseaudio-equalizer package;
2. Play around with it;
3. Uninstall the package.

Actual results:
System won't recognize the sound card anymore.

Expected results:
Package is uninstalled cleanly.

Additional info:
The issue persisted across reboots.
Comment 1 Jaromír Cápík 2015-08-19 11:52:12 EDT
Hello Martín.

> I installed this PulseAudio addon in order to bring a system-wide equalizer,
> however because the sound quality was very choppy

How do you mean that? Was the sound distorted or randomly interrupted causing delays in playing? The first can be caused by wrong configuration of frequancy levels. Since it is a digital equalizer without soft clipping, you should always keep the levels below 0.0dB unless you need it for special cases.


> later I decided to
> uninstall it. Problem is that after uninstalling the package the sound card
> (built-in) isn't recognized anymore.

How do you mean 'isn't recognized' ? Does it mean your players stopped playing throwing error messages?
Sorry, I'm unable to reproduce this (trying with Audacious and VLC). After uninstalling the equalizer and restarting the players I get a sound without equalization.
Comment 2 Martín Cigorraga 2015-08-19 12:23:34 EDT
Hello Jaromír,

Well, this is a bit ackward... I tried to reproduce the issue moments ago just to be sure before answering you but this time everything works well after uninstalling the package -- even across reboots.

I'm sorry for wasting your time :P

Best.
Comment 3 Jaromír Cápík 2015-08-20 13:19:57 EDT
(In reply to Martín Cigorraga from comment #2)
> Hello Jaromír,
> 
> Well, this is a bit ackward... I tried to reproduce the issue moments ago
> just to be sure before answering you but this time everything works well
> after uninstalling the package -- even across reboots.
> 
> I'm sorry for wasting your time :P

Np. I trust you it happened. However, it's difficult to resolve any issue without reliable reproducer. The issue could depend on specific conditions and that's always difficult to debug. Feel free to reopen this if it happens again and we could try to debug on your computer.

Regards,
Jaromir.

Note You need to log in before you can comment on or make changes to this bug.