Bug 1254071 - [abrt] guake: guake_app.py:308:__init__:SystemError: NULL result without error in PyObject_Call
[abrt] guake: guake_app.py:308:__init__:SystemError: NULL result without erro...
Status: CLOSED DUPLICATE of bug 1248754
Product: Fedora
Classification: Fedora
Component: guake (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pierre-YvesChibon
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:cab81c41ac19476dd1630376102...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 02:23 EDT by Jiri Popelka
Modified: 2015-11-11 09:04 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-11 03:46:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.46 KB, text/plain)
2015-08-17 02:23 EDT, Jiri Popelka
no flags Details
File: environ (2.02 KB, text/plain)
2015-08-17 02:23 EDT, Jiri Popelka
no flags Details

  None (edit)
Description Jiri Popelka 2015-08-17 02:23:06 EDT
Description of problem:
Trying to start Guake

Version-Release number of selected component:
guake-0.7.2-3.fc23

Additional info:
reporter:       libreport-2.6.2
cmdline:        python2 -m guake.main
dso_list:       python-libs-2.7.10-4.fc23.x86_64
executable:     /usr/lib64/python2.7/site-packages/guake/main.py
kernel:         4.1.3-200.fc22.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
guake_app.py:308:__init__:SystemError: NULL result without error in PyObject_Call

Traceback (most recent call last):
  File "/usr/lib64/python2.7/runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib64/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/usr/lib64/python2.7/site-packages/guake/main.py", line 239, in <module>
    exec_main()
  File "/usr/lib64/python2.7/site-packages/guake/main.py", line 235, in exec_main
    if not main():
  File "/usr/lib64/python2.7/site-packages/guake/main.py", line 151, in main
    instance = Guake()
  File "/usr/lib64/python2.7/site-packages/guake/guake_app.py", line 308, in __init__
    self.hotkeys = guake.globalhotkeys.GlobalHotkey()
SystemError: NULL result without error in PyObject_Call

Local variables in innermost frame:
colormap: <gtk.gdk.Colormap object at 0x7f1d24af3690 (GdkColormap at 0x5626f432b1c0)>
img: '/usr/share/pixmaps/guake/guake-tray.png'
evtbox: <gtk.EventBox object at 0x7f1d2564f0f0 (GtkEventBox at 0x5626f4301a50)>
screen: <gtk.gdk.ScreenX11 object at 0x7f1d24af3640 (GdkScreenX11 at 0x5626f4137780)>
composited_changed: <function composited_changed at 0x7f1d24af1410>
self: Guake(path="/usr/share/guake/guake.glade")
hide_context_menu: <function hide_context_menu at 0x7f1d24af1500>
destroy: <function destroy at 0x7f1d24af1578>
window_event: <function window_event at 0x7f1d24af15f0>
double_click: <function double_click at 0x7f1d24af1488>

Potential duplicate: bug 1248754
Comment 1 Jiri Popelka 2015-08-17 02:23:09 EDT
Created attachment 1063627 [details]
File: backtrace
Comment 2 Jiri Popelka 2015-08-17 02:23:10 EDT
Created attachment 1063628 [details]
File: environ
Comment 3 Jiri Popelka 2015-09-11 03:46:32 EDT

*** This bug has been marked as a duplicate of bug 1248754 ***

Note You need to log in before you can comment on or make changes to this bug.