Bug 1254084 - There is messy code under the output of command 'sg_dd'
There is messy code under the output of command 'sg_dd'
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sg3_utils (Show other bugs)
7.2
ppc64le Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: David Sommerseth
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 03:01 EDT by Gu Nini
Modified: 2016-05-22 19:35 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-24 07:02:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gu Nini 2015-08-17 03:01:26 EDT
Description of problem:
When issue SCSI INQUIRY related command 'sg_dd' in as ppc64 le host/guest, there is some messy code under the output.

Version-Release number of selected component (if applicable):
Host kernel: 3.10.0-304.el7.ppc64le
sg3_utils: sg3_utils-1.37-5.el7.ppc64le

How reproducible:
100%


Steps to Reproduce:
1. Install the latest sg3_utils on a ppc64le host/guest

2. Create a scsi_debug disk in the host/guest:
#modprobe scsi_debug lbpu=1 lbpws=1
#lsscsi
......
[0:2:4:0]    disk    IBM      IPR-0   5DBA7D00       /dev/sde 
[0:3:0:0]    no dev  IBM      57D7001SISIOA    0150  -        
[1:0:0:0]    disk    Linux    scsi_debug       0004  /dev/sdf

3. Issue command 'sg_dd' for the scsi_debug disk in the host/guest:
[root@ibm-p8-rhevm-10 home]# sg_dd if=/dev/sdf blk_sgio=1 bs=512 count=1
a%c
   !�8U�1+0 records in
1+0 records out

Actual results:
There is messy code in the command output as showed in step3

Expected results:
There isn't any messy code in the command output

Additional info:
Comment 2 Thomas Huth 2015-08-20 15:19:40 EDT
I think this is not a bug: Since you did not specify the "of=..." paramater here, the output of the read buffer gets written to stdout, causing these strange characters. If you want to suppress the output, simply use something like "of=/dev/null" or so as additional parameter.
Comment 3 Gu Nini 2015-08-24 07:02:09 EDT
(In reply to Thomas Huth from comment #2)
> I think this is not a bug: Since you did not specify the "of=..." paramater
> here, the output of the read buffer gets written to stdout, causing these
> strange characters. If you want to suppress the output, simply use something
> like "of=/dev/null" or so as additional parameter.

Thomas,

You are right, thanks, close the bug directly.

Note You need to log in before you can comment on or make changes to this bug.