Bug 1254086 - nova quota-show reports the default quota if we specify a non existing uuid
nova quota-show reports the default quota if we specify a non existing uuid
Status: CLOSED CANTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
6.0 (Juno)
Unspecified Unspecified
low Severity low
: ga
: 10.0 (Newton)
Assigned To: Eoghan Glynn
nlevinki
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 03:07 EDT by Eduard Barrera
Modified: 2016-02-26 10:21 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-26 10:21:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eduard Barrera 2015-08-17 03:07:26 EDT
Description of problem:

When we want to see the quota of a tenant nova is reporting the default quota when the parameter is a non-existing uuid.  If the parameter is the tenant name nova reports the default quotas also thus it is an non existing uuid causing confusion

Version-Release number of selected component (if applicable):
Reported for Havana and reproduced in Juno, probably icehouse is afected too

How reproducible:
always

Steps to Reproduce:

# nova quota-show --tenant  tenantvlan1

+-----------------------------+-------+
| Quota                       | Limit |
+-----------------------------+-------+
| instances                   | 10    |
| cores                       | 20    |
| ram                         | 250   |
| floating_ips                | 10    |
| fixed_ips                   | -1    |
| metadata_items              | 128   |
| injected_files              | 5     |
| injected_file_content_bytes | 10240 |
| injected_file_path_bytes    | 255   |
| key_pairs                   | 100   |
| security_groups             | 10    |
| security_group_rules        | 20    |
| server_groups               | 10    |
| server_group_members        | 10    |
+-----------------------------+-------+

# nova quota-show --tenant  ba0008f1edc741eb9b45722f7d43c250


+-----------------------------+-------+
| Quota                       | Limit |
+-----------------------------+-------+
| instances                   | 5     |
| cores                       | 11    |
| ram                         | 111   |
| floating_ips                | 10    |
| fixed_ips                   | -1    |
| metadata_items              | 128   |
| injected_files              | 2     |
| injected_file_content_bytes | 11    |
| injected_file_path_bytes    | 255   |
| key_pairs                   | 100   |
| security_groups             | 10    |
| security_group_rules        | 20    |
| server_groups               | 10    |
| server_group_members        | 10    |
+-----------------------------+-------+




Actual results:
nova reports the default quota if we provide a non existing uuid

Expected results:
report uuid not found


Additional info:
The same behaviour is observer with the command #cinder quota-show, reporting it as a separate bug bz#1254085
Comment 5 Sven Anderson 2016-02-26 10:21:13 EST
Although this is a bit weird behavior, this basically works as intended. Changing this behavior, and getting the information to report "uuid not found", would mean a considerable amount of changes in how nova works.

Note You need to log in before you can comment on or make changes to this bug.