Bug 125409 - Xlib: extension "XFree86-DRI" missing on display ":0.0" when connecting via SSH
Xlib: extension "XFree86-DRI" missing on display ":0.0" when connecting via SSH
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
2
i386 Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-06 10:36 EDT by Alan O'Neill
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-23 11:54:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan O'Neill 2004-06-06 10:36:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
I have several Linux machines networked together.  For the problem
that I am reporting, I will talk about the one that runs RedHat Linux
9.0 and the one that runs Fedora Core 2 (recently installed).

I use ssh to connect from one machine to another to run GUI based
applications.  When I ssh from RH9 to FC2 and run a graphical
application, things work fine.  When I ssh from FC2 to RH9 and run a
graphical application, the application works, but I receive the
message shown in the example below, and I notice that things run more
slowly.  RH9 is running on an AMD 2400 w/ 1 gig RAM, nd FC2 is running
on an AMD 2500 w/ 512 meg RAM, so I don't expect that the difference
in speed is due to this small difference.

Example:

[alan@snoopy alan]$ kwrite &
[1] 25078
[alan@snoopy alan]$ Xlib:  extension "XFree86-DRI" missing on display
":0.0".
libGL error: failed to open DRM: Operation not permitted
libGL error: reverting to (slow) indirect rendering
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
libGL error: failed to open DRM: Operation not permitted
libGL error: reverting to (slow) indirect rendering

When I installed FC2, I downloaded the iso's, installed them, and ran
up2date to get all updates.  At this point, all updates have been
applied.  I last updated RH9 when the updates were still being
released.  I personally have made no changes to the X configuration on
either machine, so all settings should be what came along with the
installation or any updates from up2date.

kinfocenter on FC2 reports vendor release number 60,700,000; version
11.0 while it reports vendor release number 40,700,000; version 11.0
on RH9.

Any help would be appreciated.

Version-Release number of selected component (if applicable):
60,700,000

How reproducible:
Always

Steps to Reproduce:
1.While running X on FC2, ssh from FC2 to RH9.
2.Start any GUI application (e.g., kwrite).
3.The message is immediately displayed on the konsole.
    

Actual Results:  The GUI application runs, though it runs more slowly
than expected, presumably due to the slower rendering.

Expected Results:  The 'Xlib:  extension "XFree86-DRI" missing on
display ":0.0"' message is not displayed when ssh-ing from RH9 to FC2.
 I am hoping not to revert to indirect rendoring when ssh-ing from FC2
to RH9.

Additional info:

In the example below, I have already established an ssh session from
FC2 to RH9.

[alan@snoopy alan]$ kwrite &
[1] 25078
[alan@snoopy alan]$ Xlib:  extension "XFree86-DRI" missing on display
":0.0".
libGL error: failed to open DRM: Operation not permitted
libGL error: reverting to (slow) indirect rendering
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
libGL error: failed to open DRM: Operation not permitted
libGL error: reverting to (slow) indirect rendering
Comment 1 Alan Cox 2004-06-18 22:04:55 EDT
This is because KDE didn't use to ask for DRI. KDE now asks for DRI
and causes this message to occur on every program startup it does. Its
harmless and basically a complicated way of saying "remote
applications cannot use hardware direct 3D acceleration"
Comment 2 Alan O'Neill 2004-06-23 11:54:47 EDT
Thank you for clearing this up for me.  I appreciate it!

Note You need to log in before you can comment on or make changes to this bug.