Bug 1254092 - [abrt] webkitgtk4: WebCore::TextureMapperLayer::setMaskLayer(): WebKitWebProcess killed by SIGSEGV
[abrt] webkitgtk4: WebCore::TextureMapperLayer::setMaskLayer(): WebKitWebProc...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: webkitgtk4 (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Popela
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:763dc4d41a6215596a62199bd7d...
:
: 1292822 1374950 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 03:23 EDT by Matteo Settenvini
Modified: 2016-09-10 17:04 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-25 17:17:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (54.75 KB, text/plain)
2015-08-17 03:23 EDT, Matteo Settenvini
no flags Details
File: cgroup (190 bytes, text/plain)
2015-08-17 03:23 EDT, Matteo Settenvini
no flags Details
File: core_backtrace (9.04 KB, text/plain)
2015-08-17 03:23 EDT, Matteo Settenvini
no flags Details
File: dso_list (19.44 KB, text/plain)
2015-08-17 03:23 EDT, Matteo Settenvini
no flags Details
File: environ (1.94 KB, text/plain)
2015-08-17 03:23 EDT, Matteo Settenvini
no flags Details
File: limits (1.29 KB, text/plain)
2015-08-17 03:23 EDT, Matteo Settenvini
no flags Details
File: maps (156.51 KB, text/plain)
2015-08-17 03:23 EDT, Matteo Settenvini
no flags Details
File: mountinfo (3.48 KB, text/plain)
2015-08-17 03:23 EDT, Matteo Settenvini
no flags Details
File: namespaces (85 bytes, text/plain)
2015-08-17 03:23 EDT, Matteo Settenvini
no flags Details
File: open_fds (1.39 KB, text/plain)
2015-08-17 03:23 EDT, Matteo Settenvini
no flags Details
File: proc_pid_status (1023 bytes, text/plain)
2015-08-17 03:23 EDT, Matteo Settenvini
no flags Details
File: var_log_messages (28 bytes, text/plain)
2015-08-17 03:23 EDT, Matteo Settenvini
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
WebKit Project 149569 None None None Never

  None (edit)
Description Matteo Settenvini 2015-08-17 03:23:36 EDT
Version-Release number of selected component:
webkitgtk4-2.8.4-3.fc22

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /usr/libexec/webkit2gtk-4.0/WebKitWebProcess 19
crash_function: WebCore::TextureMapperLayer::setMaskLayer
executable:     /usr/libexec/webkit2gtk-4.0/WebKitWebProcess
global_pid:     7398
kernel:         4.1.4-200.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 WebCore::TextureMapperLayer::setMaskLayer at /usr/src/debug/webkitgtk-2.8.4/Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:494
 #1 WebCore::GraphicsLayerTextureMapper::commitLayerChanges at /usr/src/debug/webkitgtk-2.8.4/Source/WebCore/platform/graphics/texmap/GraphicsLayerTextureMapper.cpp:419
 #2 WebCore::GraphicsLayerTextureMapper::flushCompositingStateForThisLayerOnly at /usr/src/debug/webkitgtk-2.8.4/Source/WebCore/platform/graphics/texmap/GraphicsLayerTextureMapper.cpp:369
 #3 WebCore::GraphicsLayerTextureMapper::flushCompositingState at /usr/src/debug/webkitgtk-2.8.4/Source/WebCore/platform/graphics/texmap/GraphicsLayerTextureMapper.cpp:504
 #11 WebCore::RenderLayerCompositor::flushPendingLayerChanges at /usr/src/debug/webkitgtk-2.8.4/Source/WebCore/rendering/RenderLayerCompositor.cpp:462
 #12 WebCore::FrameView::flushCompositingStateForThisFrame at /usr/src/debug/webkitgtk-2.8.4/Source/WebCore/page/FrameView.cpp:913
 #13 WebCore::FrameView::flushCompositingStateIncludingSubframes at /usr/src/debug/webkitgtk-2.8.4/Source/WebCore/page/FrameView.cpp:1065
 #14 WebKit::LayerTreeHostGtk::flushPendingLayerChanges at /usr/src/debug/webkitgtk-2.8.4/Source/WebKit2/WebProcess/WebPage/gtk/LayerTreeHostGtk.cpp:266
 #15 WebKit::LayerTreeHostGtk::flushAndRenderLayers at /usr/src/debug/webkitgtk-2.8.4/Source/WebKit2/WebProcess/WebPage/gtk/LayerTreeHostGtk.cpp:313
 #16 WebKit::LayerTreeHostGtk::layerFlushTimerFired at /usr/src/debug/webkitgtk-2.8.4/Source/WebKit2/WebProcess/WebPage/gtk/LayerTreeHostGtk.cpp:237
Comment 1 Matteo Settenvini 2015-08-17 03:23:39 EDT
Created attachment 1063647 [details]
File: backtrace
Comment 2 Matteo Settenvini 2015-08-17 03:23:41 EDT
Created attachment 1063648 [details]
File: cgroup
Comment 3 Matteo Settenvini 2015-08-17 03:23:42 EDT
Created attachment 1063649 [details]
File: core_backtrace
Comment 4 Matteo Settenvini 2015-08-17 03:23:43 EDT
Created attachment 1063650 [details]
File: dso_list
Comment 5 Matteo Settenvini 2015-08-17 03:23:45 EDT
Created attachment 1063651 [details]
File: environ
Comment 6 Matteo Settenvini 2015-08-17 03:23:46 EDT
Created attachment 1063652 [details]
File: limits
Comment 7 Matteo Settenvini 2015-08-17 03:23:48 EDT
Created attachment 1063653 [details]
File: maps
Comment 8 Matteo Settenvini 2015-08-17 03:23:49 EDT
Created attachment 1063654 [details]
File: mountinfo
Comment 9 Matteo Settenvini 2015-08-17 03:23:51 EDT
Created attachment 1063655 [details]
File: namespaces
Comment 10 Matteo Settenvini 2015-08-17 03:23:52 EDT
Created attachment 1063656 [details]
File: open_fds
Comment 11 Matteo Settenvini 2015-08-17 03:23:53 EDT
Created attachment 1063657 [details]
File: proc_pid_status
Comment 12 Matteo Settenvini 2015-08-17 03:23:56 EDT
Created attachment 1063658 [details]
File: var_log_messages
Comment 13 Michael Catanzaro 2016-03-01 19:10:12 EST
*** Bug 1292822 has been marked as a duplicate of this bug. ***
Comment 14 Michael Catanzaro 2016-09-10 17:04:43 EDT
*** Bug 1374950 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.