This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1254134 - Failed to start firewalld - dynamic firewall daemon
Failed to start firewalld - dynamic firewall daemon
Status: CLOSED DUPLICATE of bug 1254077
Product: Fedora
Classification: Fedora
Component: python-slip (Show other bugs)
rawhide
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 05:04 EDT by poma
Modified: 2015-08-17 08:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-17 08:01:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description poma 2015-08-17 05:04:58 EDT
Starting firewalld - dynamic firewall daemon...
firewalld.service: Main process exited, code=exited, status=1/FAILURE
Failed to start firewalld - dynamic firewall daemon.
firewalld.service: Unit entered failed state.
firewalld.service: Failed with result 'exit-code'.


# firewalld --nofork
Traceback (most recent call last):
  File "/usr/sbin/firewalld", line 176, in <module>
    main()
  File "/usr/sbin/firewalld", line 171, in main
    startup(args)
  File "/usr/sbin/firewalld", line 127, in startup
    from firewall.server import server
  File "/usr/lib/python3.4/site-packages/firewall/server/server.py", line 38, in <module>
    import slip.dbus
  File "/usr/lib/python3.4/site-packages/slip/dbus/__init__.py", line 8, in <module>
    from . import service
  File "/usr/lib/python3.4/site-packages/slip/dbus/service.py", line 32, in <module>
    from .._wrappers import _glib as GLib
ImportError: cannot import name '_glib'


# rpm -qf /usr/lib/python3.4/site-packages/slip/dbus/__init__.py
python3-slip-dbus-0.6.2-1.fc24.noarch
# rpm -qf /usr/lib/python3.4/site-packages/slip/dbus/service.py
python3-slip-dbus-0.6.2-1.fc24.noarch
Comment 1 Nils Philippsen 2015-08-17 08:01:41 EDT

*** This bug has been marked as a duplicate of bug 1254077 ***

Note You need to log in before you can comment on or make changes to this bug.