Bug 1254139 - Multipath FC physical machine has device.map containing /dev/mapper/mpatha and virt-p2v does not know how to rewrite this
Multipath FC physical machine has device.map containing /dev/mapper/mpatha an...
Status: CLOSED DUPLICATE of bug 1253223
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs (Show other bugs)
7.2
x86_64 Unspecified
medium Severity medium
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
P2V
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 05:23 EDT by mxie@redhat.com
Modified: 2015-09-01 23:05 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-01 10:27:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of RHEL7.2-x64 guest disk info (264.79 KB, image/png)
2015-08-17 05:23 EDT, mxie@redhat.com
no flags Details
Conversion log of RHEL7.2-x86_64-FC (133.98 KB, application/zip)
2015-08-18 01:00 EDT, mxie@redhat.com
no flags Details
Conversion log of wfrhel6.7-32 - Comment 4 (58.64 KB, text/plain)
2015-08-18 04:25 EDT, fwu
no flags Details

  None (edit)
Description mxie@redhat.com 2015-08-17 05:23:12 EDT
Created attachment 1063740 [details]
screenshot of RHEL7.2-x64 guest disk info

Description of problem:
device.map of RHEL7.2-x86_64 guest which is converted from RHEL7.2-x86_64 FC host to RHEV by virt-p2v
isn't updated correctly 

Version-Release number of selected component (if applicable):
virt-v2v-1.28.1-1.49.el7.x86_64
virt-p2v-1.28.1-1.49.el7-1.iso

How reproducible:
100%

Steps to Reproduce:
 1.Install rhel7.2-x86_64 on FC storage
 2.Boot into rhel7.2-x86_64 and check disk info original of OS host as below:
  #cat /boot/grub2/device.map
   # this device map was generated by anaconda
   (hd0)      /dev/mapper/mpatha
   (hd1)      /dev/mapper/mpatha

  # lsblk
   NAME                                                  MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
   sda                                                     8:0    0 232.9G  0 disk  
   ├─sda1                                                  8:1    0   243M  0 part  
   ├─sda2                                                  8:2    0   244M  0 part  
   ├─sda3                                                  8:3    0   244M  0 part  
   └─sda4                                                  8:4    0 232.1G  0 part  
     ├─HostVG-Swap                                       253:11   0   7.9G  0 lvm   
     ├─HostVG-Config                                     253:12   0     8M  0 lvm   
     ├─HostVG-Logging                                    253:13   0     2G  0 lvm   /run/media
     └─HostVG-Data                                       253:14   0 222.3G  0 lvm   /run/media
   sdb                                                     8:16   0    20G  0 disk  
   └─mpatha                                              253:1    0    20G  0 mpath 
     └─mpatha1                                           253:2    0    20G  0 part  /
   sdc                                                     8:32   0   1.2T  0 disk  
   └─mpathb                                              253:0    0   1.2T  0 mpath 
     ├─45729e32--8959--4d58--89aa--0ee0ab61dc36-metadata 253:3    0   512M  0 lvm   
     ├─45729e32--8959--4d58--89aa--0ee0ab61dc36-outbox   253:4    0   128M  0 lvm   
     ├─45729e32--8959--4d58--89aa--0ee0ab61dc36-leases   253:5    0     2G  0 lvm   
     ├─45729e32--8959--4d58--89aa--0ee0ab61dc36-ids      253:6    0   128M  0 lvm   
     ├─45729e32--8959--4d58--89aa--0ee0ab61dc36-inbox    253:7    0   128M  0 lvm   
     ├─45729e32--8959--4d58--89aa--0ee0ab61dc36-master   253:8    0     1G  0 lvm   /run/media
     ├─45729e32--8959--4d58--89aa--0ee0ab61dc36-888004a8--c6a8--41b5--a5f0--00ba94028458
                                                      253:9    0   5.9G  0 lvm   
     └─45729e32--8959--4d58--89aa--0ee0ab61dc36-6efe101f--3992--4193--a1e2--03104a1ef5a0
                                                      253:10   0   5.9G  0 lvm   
   sdd                                                     8:48   0    20G  0 disk  
   └─mpatha                                              253:1    0    20G  0 mpath 
     └─mpatha1                                           253:2    0    20G  0 part  /
   sde                                                     8:64   0   1.2T  0 disk  
   └─mpathb                                              253:0    0   1.2T  0 mpath 
     ├─45729e32--8959--4d58--89aa--0ee0ab61dc36-metadata 253:3    0   512M  0 lvm   
     ├─45729e32--8959--4d58--89aa--0ee0ab61dc36-outbox   253:4    0   128M  0 lvm   
     ├─45729e32--8959--4d58--89aa--0ee0ab61dc36-leases   253:5    0     2G  0 lvm   
     ├─45729e32--8959--4d58--89aa--0ee0ab61dc36-ids      253:6    0   128M  0 lvm   
     ├─45729e32--8959--4d58--89aa--0ee0ab61dc36-inbox    253:7    0   128M  0 lvm   
     ├─45729e32--8959--4d58--89aa--0ee0ab61dc36-master   253:8    0     1G  0 lvm   /run/media
     ├─45729e32--8959--4d58--89aa--0ee0ab61dc36-888004a8--c6a8--41b5--a5f0--00ba94028458
                                                      253:9    0   5.9G  0 lvm   
     └─45729e32--8959--4d58--89aa--0ee0ab61dc36-6efe101f--3992--4193--a1e2--03104a1ef5a0
                                                      253:10   0   5.9G  0 lvm   
   sr0                                                    11:0    1     3G  0 rom   /run/media


 3.Boot the source machine into virt-p2v via PXE and input the ip and password of conversion server.
 4.Convert rhel7.2-x86_64 FC host to RHEV via virt-p2v client
 5.After conversion,boot into rhel7.2-x86_64 guest and check points on RHEV
 6.Check disk info of rhel7.2-x86_64 guest on RHEV as below and device.map is not updated to vda
   #cat /boot/grub2/device.map
    # this device map was generated by anaconda
    (hd0)      /dev/mapper/mpatha
    (hd1)      /dev/mapper/mpatha

   #lsblk
    NAME   MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT
    sr0     11:0    1 1024M  0 rom  
    vda    253:0    0   20G  0 disk 
    └─vda1 253:1    0   20G  0 part /

Actual results:
device.map of RHEL7.2-x86_64 guest isn't updated to vda on RHEV 

Expected results:
device.map of RHEL7.2-x86_64 guest should be updated to vda on RHEV 

Additional info:
Comment 2 Richard W.M. Jones 2015-08-17 13:26:37 EDT
Can you grab the virt-v2v conversion log file from the
virt-v2v conversion server.  It should be located in /tmp
in a file called something like:

 /tmp/virt-p2v-20150817-xxxxxx/virt-v2v-conversion-log.txt
Comment 3 mxie@redhat.com 2015-08-18 01:00:11 EDT
Created attachment 1064162 [details]
Conversion log of RHEL7.2-x86_64-FC
Comment 4 fwu 2015-08-18 01:16:46 EDT
Similar problem occurs when I use RHEL6.7-i386 host installed in SATA/ATA-ahci device converting to KVM server via virt-p2v client. The version of virt-p2v client is the same as Comment 0 describes.
After conversion, check disk info of RHEL6.7-i386 guest on KVM server and device.map is not updated to vda.
   #cat /boot/grub2/device.map
    # this device map was generated by anaconda
    (hd0)      /dev/sda
   #lsblk
    NAME   MAJ:MIN RM   SIZE  RO TYPE  MOUNTPOINT
    vda    253:0    0 149.1G  0  disk 
    └─vda1 253:1    0 141.6G  0  part  /
    └─vda2 253:2    0   7.5G  0  part  [SWAP]
Comment 5 fwu 2015-08-18 04:25:53 EDT
Created attachment 1064226 [details]
Conversion log of wfrhel6.7-32 - Comment 4
Comment 6 Richard W.M. Jones 2015-08-18 08:21:37 EDT
(In reply to fwu from comment #4)
> Similar problem occurs when I use RHEL6.7-i386 host installed in
> SATA/ATA-ahci device converting to KVM server via virt-p2v client. The
> version of virt-p2v client is the same as Comment 0 describes.
> After conversion, check disk info of RHEL6.7-i386 guest on KVM server and
> device.map is not updated to vda.
>    #cat /boot/grub2/device.map
>     # this device map was generated by anaconda
>     (hd0)      /dev/sda
>    #lsblk
>     NAME   MAJ:MIN RM   SIZE  RO TYPE  MOUNTPOINT
>     vda    253:0    0 149.1G  0  disk 
>     └─vda1 253:1    0 141.6G  0  part  /
>     └─vda2 253:2    0   7.5G  0  part  [SWAP]

This isn't the same thing.  Please open a new bug about it.
Also the log attached in comment 5 is incomplete.  It's possibly
the wrong log, or the log of a different run.
Comment 7 fwu 2015-08-19 02:03:32 EDT
I have reported a new bug: Bug 1254857 according to Comment 5.
The log file has been corrected and I think this time it will be complete!
Additionally, the same problem occurs on iSCSI device. Therefore, this issue was added on the bug mentioned above.
Thanks for your help, Richard!
Comment 8 Richard W.M. Jones 2015-09-01 10:27:20 EDT
Actually now I look at this closely, I see this is another case
of the Anaconda bug.

The device.map is wrong since it does not agree with the lsblk output.

*** This bug has been marked as a duplicate of bug 1253223 ***
Comment 9 mxie@redhat.com 2015-09-01 23:05:46 EDT
(In reply to Richard W.M. Jones from comment #8)
> Actually now I look at this closely, I see this is another case
> of the Anaconda bug.
> 
> The device.map is wrong since it does not agree with the lsblk output.
> 
> *** This bug has been marked as a duplicate of bug 1253223 ***


Hi Richard

  I think FC host's device.map is coincide with lsblk output,pls refer to below info of FC host, sdd is my fc storage in lsblk output and it is also mpatha, besides, I think this bug is not duplicate with bug 1253223

  #cat /boot/grub2/device.map
   # this device map was generated by anaconda
   (hd0)      /dev/mapper/mpatha
   (hd1)      /dev/mapper/mpatha

  # lsblk
   NAME                                                  MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
     sdd                                                     8:48   0    20G  0 disk  
   └─mpatha                                              253:1    0    20G  0 mpath 
     └─mpatha1                                           253:2    0    20G  0 part  /

Thanks

Note You need to log in before you can comment on or make changes to this bug.