Bug 1254241 - [RFE] Supported Browser Matrix References Latest That Seems Too Vague or Not Right
[RFE] Supported Browser Matrix References Latest That Seems Too Vague or Not ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Install Guide (Show other bugs)
Unspecified
Unspecified Unspecified
medium Severity medium (vote)
: Beta
: 6.2
Assigned To: Allison Heslin
Brandi
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 09:43 EDT by Dave Sullivan
Modified: 2016-10-26 21:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-26 21:44:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Sullivan 2015-08-17 09:43:50 EDT
Document URL: 

https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.1/html/Installation_Guide/sect-Red_Hat_Satellite-Installation_Guide-Prerequisites.html#form-Red_Hat_Satellite-Installation_Guide-Prerequisites-Supported_Browsers

Section Number and Name: 

Table 1.1 Supported Browser Matrix

Describe the issue: 

The table references "latest" as L1 fully supported.

Browser updates tend to move fairly fast so the message around "latest" can be confusing.  What does it really mean?

Does it mean the last one we tested, if so what version was that?

Does it mean the latest version provided by Browser XYZ?  And if so we now provide support for things in the future, that we haven't even tested yet.

Suggestions for improvement: 

If you look at Firefox we see support for 22,23,24 then latest.  I think we should document a latest version tested and provide the version.

If we want to make a general statement that we work to support latest versions I think that is ok, but I don't think we should just say latest.  That gives me know idea what version Red Hat has actually tested.

Additional information: 

Here's an example of why this is important.

https://bugzilla.redhat.com/show_bug.cgi?id=1166307#c12

We say we support latest, but I don't know what version that means.

I can see customer tested on 31.8 but not sure what we tested and not sure what version latest refers to.  Do I move the customer backward to version 24, or do I move them forward.  If I move them forward I'm not sure if we have even tested there, so there are some reservations for doing so.
Comment 1 Dave Sullivan 2015-08-17 09:52:31 EDT
In general it seems every major dot release should get a new latest version tested and supported added to the support matrix, versus just a "latest".

As thinking latest should more of statement we are committed to latest browser support.  Although we may not have tested with the actual latest.

So two requests here.

1. For each dot release provide a latest version tested to the table
2. Provide a generic statement that Red Hat Satellite is committed to supporting the latest browser versions.
Comment 2 Allison Heslin 2016-02-16 10:14:04 EST
Working on this as part of the Installation Guide revision for 6.2.
Comment 3 Mike McCune 2016-03-28 18:13:31 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 4 Allison Heslin 2016-04-14 08:56:09 EDT
I updated the latest browser versions in the Installation Guide for 6.2-Beta. It might be that we need to rethink how we present browser requirements in the Installation Guide because they do change so frequently. Leaving this bug as Post until that question has been resolved.
Comment 5 Allison Heslin 2016-07-05 13:36:46 EDT
These were updated again. I'm going to close this for 6.2.
Comment 6 Andrew Dahms 2016-10-26 21:44:23 EDT
This content is now live on the Customer Portal.

Closing.

Note You need to log in before you can comment on or make changes to this bug.