Bug 1254295 - Wrong cardinality of host.storage_domain_extensions, unbounded instead of 1
Wrong cardinality of host.storage_domain_extensions, unbounded instead of 1
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-api (Show other bugs)
3.6
Unspecified Unspecified
unspecified Severity unspecified
: m1
: 3.6.0
Assigned To: Juan Hernández
Raz Tamir
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 12:07 EDT by Juan Hernández
Modified: 2016-03-10 01:13 EST (History)
10 users (show)

See Also:
Fixed In Version: 3.6.0-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-04 06:21:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 44986 master MERGED restapi: Fix the cardinality storage connection extensions Never
oVirt gerrit 45024 ovirt-engine-3.6 MERGED restapi: Fix the cardinality storage connection extensions Never

  None (edit)
Description Juan Hernández 2015-08-17 12:07:21 EDT
The XML schema definition of the host.storage_domain_extensions specifies "unbounded" for the "maxoccurs" attribute. This is wrong, and as a result the getter method of the Java class generated by the XJC compiler returns a list:

  List<StorageConnectionExtensions> getStorageConnectionExtensions() {
    ...
  }

This isn't an issue for the server, as this method isn't used at all. But it induces a compilation error in the Java SDK because the code generator assumes that this method returns only one element, and the code generated for the host decorator overrides it as follows:

  HostStorageConnectionExtensions getStorageConnectionExtensions() {
    ...
  }

The XML schema needs to be modified so that the value of maxoccurs is 1 instead of unbounded.
Comment 1 Raz Tamir 2015-08-23 07:37:09 EDT
Verified - rhevm-3.6.0-0.12.master.el6.noarch
Comment 2 Sandro Bonazzola 2015-11-04 06:21:33 EST
oVirt 3.6.0 has been released on November 4th, 2015 and should fix this issue.
If problems still persist, please open a new BZ and reference this one.

Note You need to log in before you can comment on or make changes to this bug.