Bug 1254373 - ImportError: cannot import name indexbytes (python package six)
ImportError: cannot import name indexbytes (python package six)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: deluge (Show other bugs)
22
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Michael Cronenworth
Fedora Extras Quality Assurance
:
: 1258568 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 18:00 EDT by Rabin
Modified: 2015-10-07 19:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-17 19:08:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rabin 2015-08-17 18:00:22 EDT
Description of problem:

Deluge won't start.
it will exit with this traceback

[ERROR   ] 00:20:48 ui:168 cannot import name indexbytes
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/deluge/ui/ui.py", line 149, in __init__
    from deluge.ui.gtkui.gtkui import GtkUI
  File "/usr/lib/python2.7/site-packages/deluge/ui/gtkui/__init__.py", line 1, in <module>
    from gtkui import start
  File "/usr/lib/python2.7/site-packages/deluge/ui/gtkui/gtkui.py", line 87, in <module>
    from deluge.ui.client import client
  File "/usr/lib/python2.7/site-packages/deluge/ui/client.py", line 37, in <module>
    from twisted.internet import reactor, ssl, defer
  File "/usr/lib64/python2.7/site-packages/twisted/internet/ssl.py", line 59, in <module>
    from OpenSSL import SSL
  File "/usr/lib/python2.7/site-packages/OpenSSL/__init__.py", line 8, in <module>
    from OpenSSL import rand, crypto, SSL
  File "/usr/lib/python2.7/site-packages/OpenSSL/SSL.py", line 10, in <module>
    from six import int2byte, indexbytes
ImportError: cannot import name indexbytes
[ERROR   ] 00:20:48 ui:169 There was an error whilst launching the request UI: gtk
[ERROR   ] 00:20:48 ui:170 Look at the traceback above for more information.


Version-Release number of selected component (if applicable):

rpm -qa | grep deluge

deluge-daemon-1.3.11-3.fc22.noarch
deluge-gtk-1.3.11-3.fc22.noarch
deluge-common-1.3.11-3.fc22.noarch
deluge-console-1.3.11-3.fc22.noarch
deluge-images-1.3.11-3.fc22.noarch
deluge-web-1.3.11-3.fc22.noarch
deluge-1.3.11-3.fc22.noarch

How reproducible:

Every time (in my case)

Steps to Reproduce:
1. try to run deluge from the terminal

Actual results:
BOOM, CRASH, DEAD

Expected results:
Rainbow and sunshine

Additional info:
Comment 1 Rabin 2015-08-17 19:08:40 EDT
resolved by uninstalling six
and installing back

http://forum.deluge-torrent.org/viewtopic.php?f=7&t=52055&p=214751#p214751
Comment 2 Calum 2015-10-07 19:02:47 EDT
*** Bug 1258568 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.