Bug 1254378 - sssd not returning proper search query
sssd not returning proper search query
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd (Show other bugs)
6.5
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: SSSD Maintainers
Kaushik Banerjee
:
Depends On:
Blocks: 1172231
  Show dependency treegraph
 
Reported: 2015-08-17 18:18 EDT by Striker Leggette
Modified: 2015-09-04 02:00 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-04 02:00:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Striker Leggette 2015-08-17 18:18:34 EDT
Description of problem:
- RHEL 6 SSSD client of RHEL 7 IPA Server that has a trust with AD
- When querying RHEL 7 IPA Host for user information from AD, IPA Host returns wrong information and the query fails due to this.

Version-Release number of selected component (if applicable):
- Not sure if this is an issue with RHEL 7.1 SSSD or RHEL 6.5 SSSD
- ssd-1.12.2-58.el7_1.6.x86_64
- sssd-1.12.4-47.el6.x86_64

How reproducible:
- Always

Steps to Reproduce:
1. Configure RHEL 7 IPA Host with SSSD and trust to AD
2. Configure RHEL 6 IPA Client with SSSD
3. Attempt 'id' on AD user from RHEL 6 Client

Actual results:
- Nothing found

Expected results:
- Information of user returned

Additional info:
- 'id' works on the RHEL 7 machine to query AD users
Comment 11 Lukas Slebodnik 2015-08-31 07:18:35 EDT
SSSD on server side is not able to connect to Active Directory and therefore sssd went to offline mode. IIRC some work in this area was done as part of rhel7.2 time frame; So SSSD should handle problematic subdomains more gracefully. Jakub might know better.
Comment 13 Jakub Hrozek 2015-08-31 10:01:26 EDT
(In reply to Lukas Slebodnik from comment #11)
> SSSD on server side is not able to connect to Active Directory and therefore
> sssd went to offline mode. IIRC some work in this area was done as part of
> rhel7.2 time frame; So SSSD should handle problematic subdomains more
> gracefully. Jakub might know better.

Hmm, I'm not sure what improvements specifically you mean here, but I agree this bug looks like a DNS issue.

Note You need to log in before you can comment on or make changes to this bug.