Bug 1254409 - Sending a nmi to guest from qemu, guest can not generate vmcore file
Sending a nmi to guest from qemu, guest can not generate vmcore file
Status: CLOSED DUPLICATE of bug 1254406
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
7.2
x86_64 Linux
medium Severity high
: rc
: ---
Assigned To: Radim Krčmář
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 23:35 EDT by Yanan Fu
Modified: 2015-09-17 08:01 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-17 08:01:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full console output for this bug (86.18 KB, text/plain)
2015-09-17 04:35 EDT, Yanan Fu
no flags Details

  None (edit)
Description Yanan Fu 2015-08-17 23:35:22 EDT
Description of problem:
Boot a guest,and enable:
echo 1 >/proc/sys/kernel/panic_on_io_nmi
echo 1 >/proc/sys/kernel/unknown_nmi_panic
echo 1 >/proc/sys/kernel/panic_on_unrecovered_nmi 

send a nmi to guest: (qemu)nmi
guest can not generate kdump successfully.
kernal:3.10.0-304.el7.x86_64
qemu-kvm:qemu-kvm-rhev-2.3.0-17.el7.x86_64


Version-Release number of selected component (if applicable):
sometimes

How reproducible:
sometimes

Steps to Reproduce:
1.Boot a guest,and enable:
echo 1 >/proc/sys/kernel/panic_on_io_nmi
echo 1 >/proc/sys/kernel/unknown_nmi_panic
echo 1 >/proc/sys/kernel/panic_on_unrecovered_nmi 

2.send a nmi to guest: (qemu)nmi
3.guest reboot but no vmcore file.

Actual results:
guest can not generate kdump successfully.

Expected results:
guest can generate vmcore successfully.

Additional info:
CLI:
/usr/libexec/qemu-kvm -name test -machine pc,accel=kvm,usb=off,dump-guest-core=on -m 5G -cpu SandyBridge -smp 2,sockets=2,cores=1,threads=1 -no-user-config -nodefaults -monitor stdio -rtc base=utc,driftfix=slew -global kvm-pit.lost_tick_policy=discard -no-hpet -global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=1 -boot menu=on,strict=on -device pci-bridge,bus=pci.0,id=bridge1,chassis_nr=1,addr=0x5 -device ich9-usb-ehci1,id=usb,bus=bridge1,addr=0x2.0x7 -device ich9-usb-uhci1,masterbus=usb.0,firstport=0,bus=bridge1,multifunction=on,addr=0x2.0x0 -device ich9-usb-uhci2,masterbus=usb.0,firstport=2,bus=bridge1,addr=0x2.0x1 -device ich9-usb-uhci3,masterbus=usb.0,firstport=4,bus=bridge1,addr=0x2.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=bridge1,addr=0x4 -chardev socket,path=/tmp/yfu,server,nowait,id=yfu0 -netdev tap,id=hostnet,vhost=on -device virtio-net-pci,netdev=hostnet,id=net,mac=78:1a:4a:d6:b8:97,bus=bridge1,addr=0x6,bootindex=4 -vnc :0 -vga qxl -global qxl-vga.ram_size=67108864 -global qxl-vga.vram_size=33554432 -msg timestamp=on -monitor unix:/home/qmp,server,nowait -serial unix:/tmp/ttyS0,server,nowait -qmp tcp:0:4444,server,nowait -device usb-tablet,id=usb-tablet1 -device virtio-scsi-pci,id=scsi -drive file=/root/RHEL-7.2.qcow2,if=none,id=drive-virtio-scsi-disk0,format=qcow2,cache=none -device scsi-disk,bus=scsi.0,drive=drive-virtio-scsi-disk0,id=virtio-scsi-disk0,bootindex=1
Comment 2 Karen Noel 2015-08-18 09:24:01 EDT
Does this work properly in RHEL 7.1? So, is it a regression?
Comment 3 Yanan Fu 2015-08-19 04:01:05 EDT
(In reply to Karen Noel from comment #2)
> Does this work properly in RHEL 7.1? So, is it a regression?

with rhel 7.1 host, this issue still exist.
host version:
kernel:3.10.0-229.el7.x86_64
qemu:qemu-kvm-rhev-2.1.2-21.el7.x86_64
Comment 4 Radim Krčmář 2015-09-16 15:37:39 EDT
What is the chance to reproduce?
Are you using custom crashkernel in this guest as well?

Please paste the whole console output that contains a failure.
Comment 5 Yanan Fu 2015-09-17 04:33:54 EDT
(In reply to Radim Krčmář from comment #4)
> What is the chance to reproduce?
> Are you using custom crashkernel in this guest as well?
> 
> Please paste the whole console output that contains a failure.

1.with my latest test, the probability is 100% now.
2.crashkernel=128M  in my test.
3.add full console output in the attachment as kdump-nmi (begin when do "nmi" in qemu), please check.
   guest kernel:3.10.0-304.el7.x86_64
   host kernel: 3.10.0-316.el7.x86_64
        qemu-kvm:qemu-kvm-rhev-2.3.0-23.el7.x86_64
Comment 6 Yanan Fu 2015-09-17 04:35:05 EDT
Created attachment 1074356 [details]
full console output for this bug
Comment 7 Radim Krčmář 2015-09-17 08:01:48 EDT
The console output shows that the same disk-not-found problem.

*** This bug has been marked as a duplicate of bug 1254406 ***

Note You need to log in before you can comment on or make changes to this bug.