Bug 125443 - usb mouse quit working when a key pressed at the same time
Summary: usb mouse quit working when a key pressed at the same time
Status: CLOSED DUPLICATE of bug 124378
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
(Show other bugs)
Version: 2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-07 11:24 UTC by Sinan H
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:03:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sinan H 2004-06-07 11:24:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
My mouse (logitech USB optical) quit working a after a few minutes (30
sec to 5 min) when running opengl in full screen. tested with Q3, cube
and ut2003, with both KDE and GNOME (fc2 up2dated versions). The
problem doesnt occur in windowd mode. Keyboard, dri etc works still
fine. Quiting the apps doesnt resolve the problem; no mouse until
xserver restart. 


system is P4 xeon 2.4 /512Mb
radeon 7000 with xorg radeon driver

Linux cygn 2.6.5-1.358 #1 Sat May 8 09:04:50 EDT 2004 i686 i686 i386
GNU/Linux

Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-2

How reproducible:
Always

Steps to Reproduce:
1.launch Q3 (or ut2003, or cube) in full screen
2.start playing 
3.get fragged as your mouse stops responding
4. Curse and Alt+BS


Actual Results:  mouse freeze, need to restart X

Expected Results:  play until the end of the world

Additional info:

No errors msgs or whatsover, all syslogs are clean

Comment 1 Sinan H 2004-06-07 14:23:12 UTC
Tried with the gpm repeater (-R raw), via /dev/gpmdata; the behaviour
is the same...

Comment 2 Sinan H 2004-06-15 15:16:39 UTC
I guess the problem was something like a conflict on the USB ports.
Deleting all USB entry from the /etc/sysconf/hwconf and rebooting with
kudzu re-configuring everything arranged the problem.

happy fraggin'

S.

Comment 3 Sinan H 2004-08-11 17:16:49 UTC
reopening the bug...

It does not only happens in dri 3D environment but in desktop also
(tested with kde/gnome). Mouse quit working randomly when cursor is
moved when pressing a key (that's why it occured in q3 kind games).
Launching 'usbview' makes it work again, so i'm not sure that it's a
xorg bug. The previous workaround has no effect anymore...

Comment 4 Sinan H 2004-08-12 12:17:30 UTC
Same as the kernel bug #124378 (or very similar). 
the proposed solution (turning off the legacy USB emulation) works for
me. Closing.

*** This bug has been marked as a duplicate of 124378 ***

Comment 5 Red Hat Bugzilla 2006-02-21 19:03:59 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.