Bug 1254502 - New instances sometimes get the duplicate interface configured
New instances sometimes get the duplicate interface configured
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
6.0 (Juno)
Unspecified Unspecified
high Severity high
: async
: 6.0 (Juno)
Assigned To: Sahid Ferdjaoui
nlevinki
: Triaged, ZStream
: 1256860 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-18 05:28 EDT by Martin Schuppert
Modified: 2018-02-08 05:50 EST (History)
16 users (show)

See Also:
Fixed In Version: openstack-nova-2014.2.3-28.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-09 10:50:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Schuppert 2015-08-18 05:28:16 EDT
Description of problem:

during stack creation the creation sometimes fails because the resulting instance XML configuration has a duplicate configuration of the same interface:

2015-08-14 11:47:30.512 59779 ERROR nova.virt.libvirt.driver [-] Error launching a defined domain with XML: <domain type='kvm'>
  <name>instance-00000236</name>
  <uuid>5b2da962-1426-4041-a4cf-ff9be0a3b9fa</uuid>
  <metadata>
    <nova:instance xmlns:nova="http://openstack.org/xmlns/libvirt/nova/1.0">
      <nova:package version="2014.2.3-22.el7ost"/>
      <nova:name>IB-1</nova:name>
      <nova:creationTime>2015-08-14 08:47:28</nova:creationTime>
      <nova:flavor name="m1.large">
        <nova:memory>8192</nova:memory>
        <nova:disk>80</nova:disk>
        <nova:swap>0</nova:swap>
        <nova:ephemeral>0</nova:ephemeral>
        <nova:vcpus>4</nova:vcpus>
...

    <controller type='pci' index='0' model='pci-root'/>
    <interface type='bridge'>
      <mac address='fa:16:3e:05:aa:66'/>
      <source bridge='qbr93f9b490-df'/>
      <target dev='tap93f9b490-df'/>
      <model type='virtio'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0'/>
    </interface>
    <interface type='bridge'>
      <mac address='fa:16:3e:05:aa:66'/>
      <source bridge='qbr93f9b490-df'/>
      <target dev='tap93f9b490-df'/>
      <model type='virtio'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
    </interface>

=> In the following cache update request we see the duplicate interfaces:

2015-08-14 11:47:30.268 59779 DEBUG nova.network.base_api [req-de728736-7878-414b-916c-8430fea3b3c4 None] Updating cache with info: [

VIF({'profile': {}, 'ovs_interfaceid': u'93f9b490-dfbf-4b45-9551-76e00aeda13e',
'network': Network({'bridge': 'br-int', 'subnets': [Subnet({'ips': [FixedIP({'meta': {}, 'version': 4, 'type': 'fixed', 'floating_ips': [], 'address': u'192.168.1.2'})], 'version': 4, 'meta': {'dhcp_server': u'192.168.1.3'}, 'dns': [], 'routes': [], 'cidr': u'192.168.1.0/24';;;, 'gateway': IP({'meta': {}, 'version': 4, 'type': 'gateway', 'address': u'192.168.1.1'})})], 'meta': {'injected': False, 'tenant_id': u'644b7f4a65b74fd4a0313660f2aedec8'}, 'id': u'd9e09d02-822a-42c2-b265-3302aaeb67b7', 'label': u'management_net'}), 

---duplicate--->    'devname': u'tap93f9b490-df', 'vnic_type': u'normal', 'qbh_params': None, 'meta': {}, 'details': {u'port_filter': True, u'ovs_hybrid_plug': True}, 'address': u'fa:16:3e:05:aa:66', 'active': False, 'type': u'ovs', 'id': u'93f9b490-dfbf-4b45-9551-76e00aeda13e', 'qbg_params': None}),   


VIF({'profile': {}, 'ovs_interfaceid': u'93f9b490-dfbf-4b45-9551-76e00aeda13e',
'network': Network({'bridge': 'br-int', 'subnets': [Subnet({'ips': [FixedIP({'meta': {}, 'version': 4, 'type': 'fixed', 'floating_ips': [], 'address': u'192.168.1.2'})], 'version': 4, 'meta': {'dhcp_server': u'192.168.1.3'}, 'dns': [], 'routes': [], 'cidr': u'192.168.1.0/24';;;, 'gateway': IP({'meta': {}, 'version': 4, 'type': 'gateway', 'address': u'192.168.1.1'})})], 'meta': {'injected': False, 'tenant_id': u'644b7f4a65b74fd4a0313660f2aedec8'}, 'id': u'd9e09d02-822a-42c2-b265-3302aaeb67b7', 'label': u'management_net'}), 

---duplicate--->   'devname': u'tap93f9b490-df', 'vnic_type': u'normal', 'qbh_params': None, 'meta': {}, 'details': {u'port_filter': True, u'ovs_hybrid_plug': True}, 'address': u'fa:16:3e:05:aa:66', 'active': False, 'type': u'ovs', 'id': u'93f9b490-dfbf-4b45-9551-76e00aeda13e', 'qbg_params': None}),


VIF({'profile': {}, 'ovs_interfaceid': u'3c953b8c-eb58-4f73-81ab-659899c2c889',
'network': Network({'bridge': 'br-int', 'subnets': [Subnet({'ips': [FixedIP({'meta': {}, 'version': 4, 'type': 'fixed', 'floating_ips': [], 'address': u'169.254.0.4'})], 'version': 4, 'meta': {}, 'dns': [], 'routes': [], 'cidr': u'169.254.0.0/19';;;, 'gateway': IP({'meta': {}, 'version': None, 'type': 'gateway', 'address': None})})], 'meta': {'injected': False, 'tenant_id': u'644b7f4a65b74fd4a0313660f2aedec8'}, 'id': u'a5319204-c7d8-4d90-a59e-3529cd331cff', 'label': u'internal_net'}), 
...
Comment 27 Eoghan Glynn 2015-09-02 07:36:15 EDT
*** Bug 1256860 has been marked as a duplicate of this bug. ***
Comment 30 Lon Hohberger 2015-10-09 10:50:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1878.html

Note You need to log in before you can comment on or make changes to this bug.