Bug 1254507 - rh-python34 install error on EC2
rh-python34 install error on EC2
Status: CLOSED CURRENTRELEASE
Product: softwarecollections.org
Classification: Community
Component: rh-python34 (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matej Stuchlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-18 05:49 EDT by Geert Jansen
Modified: 2016-01-31 21:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-24 08:47:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Geert Jansen 2015-08-18 05:49:37 EDT
Description of problem:

Installation of rh-python34 from softwarecollections.org fails on RHEL 7.1 on Amazon EC2.


Version-Release number of selected component (if applicable):

Latest version as of install date (August 18th 2015).

How reproducible:

Always


Steps to Reproduce:

1. Launch RHEL 7.1 64-bit on Amazon AWS.
2. yum update -y && shutdown -r now
3. Follow instructions at https://www.softwarecollections.org/en/scls/rhscl/rh-python34/

Actual results:

--> Finished Dependency Resolution
Error: Package: rh-python34-python-devel-3.4.2-9.el7.centos.x86_64 (rhscl-rh-python34-epel-7-x86_64)
           Requires: scl-utils-build
Error: Package: rh-python34-python-sphinx-1.2.2-1.el7.centos.noarch (rhscl-rh-python34-epel-7-x86_64)
           Requires: texlive-threeparttable
Error: Package: rh-python34-python-sphinx-1.2.2-1.el7.centos.noarch (rhscl-rh-python34-epel-7-x86_64)
           Requires: texlive-titlesec
Error: Package: rh-python34-python-sphinx-1.2.2-1.el7.centos.noarch (rhscl-rh-python34-epel-7-x86_64)
           Requires: texlive-wrapfig
Error: Package: rh-python34-python-sphinx-1.2.2-1.el7.centos.noarch (rhscl-rh-python34-epel-7-x86_64)
           Requires: texlive-framed
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Expected results:

rh-python34 installs without error

Additional info:

Filing under "python33" as there is no component for rh-pyton34.
Comment 1 Geert Jansen 2015-08-18 06:31:47 EDT
Solution: install the optional channel.

On AWS EC2:

yum-config-manager --enable rhui-REGION-rhel-server-optional

I would suggest making this clear in the installation instruction, especially because not all SCLs require this (e.g. python33 doesn't require it).
Comment 2 Matej Stuchlik 2015-08-20 05:20:24 EDT
Thank you for the report, Geert! I'll add it to the documentation on softwarecollections.org. :)
Comment 3 Geert Jansen 2015-08-24 09:55:33 EDT
Hi,

the instructions for subscribing to the optional channel are specific to EC2. They don't work on RHN classic, or RHN subscription management, for example.

I would suggest against providing explicit instructions (as they greatly depend on where you run and there's many options), but instead mention the channel is needed and maybe create a central page on how it works in the different environments.
Comment 4 Matej Stuchlik 2015-08-28 10:57:47 EDT
(In reply to Geert Jansen from comment #3)
> Hi,
> 
> the instructions for subscribing to the optional channel are specific to
> EC2. They don't work on RHN classic, or RHN subscription management, for
> example.
> 
> I would suggest against providing explicit instructions (as they greatly
> depend on where you run and there's many options), but instead mention the
> channel is needed and maybe create a central page on how it works in the
> different environments.

Good point! The docs now just mention you need to enable the optional channel.

Note You need to log in before you can comment on or make changes to this bug.