Bug 125455 - fc2 doesn't boot
fc2 doesn't boot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-07 12:45 EDT by Mihnea Galca
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-10 15:14:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mihnea Galca 2004-06-07 12:45:11 EDT
Description of problem:
Fedora Core 2 won't boot using grub installed either on first disk mbr
or on the linux partition (on the secondary ide hard disk).

Version-Release number of selected component (if applicable):
grub from Fedora Core 2 (Tettnang)

How reproducible:
Always.

Steps to Reproduce:
1. Install fedora core 2 using boot cd and dvd.iso mounted on a ftp site
2. Choose to install the boot loader on mbr or on the linux boot partition
3. In the case, when the boot loader was installed on the linux boot
partition, the boot sector was copied to windows 2003 server partition
and the windows's loader was configured to load linux using that
sector. (dd if=/dev/boot_linux_part of=bootsect.lnx bs=512 count=1).
  
Actual results:
The booting process stops with a blank screen and the message "GRUB"
in the case when the boot sector was copied to windows partition. In
the other case (boot loader installed on mbr), grub starts and a
command prompt appears, but it doesn't want to boot linux even if I
specify by hand the grub's configuration file: grub> configfile
(hd1,0)/boot/grub/grub.conf.

Expected results:
Linux to boot.

Additional info:

System configuration:
PIII 650Mhz, 512Mb SDRAM, 440BX MB
/dev/hda1 - 15gb - ntfs windows 2003
/dev/hdb1 - 9gb - ext3
/dev/hdb2 - 512mb - swap

I don't know if it is related with the LBA/BIOS grub error.

Before, I've used RH 9 also with grub and I had no problem.
Comment 1 Hal Arthurs 2004-06-07 22:36:15 EDT
I have tried to install FC2 5 times on my P4 system and have the same 
result every time.  The system starts to boot and then hangs with the 
message "Grub Read Error".

I have WinXP on the first 120G HD, NTFS, and the 2nd HD is 120G 
totally for Linux.
The install goes without a problem every time, but, I cannot get past 
the read error.

Comment 2 David Balažic 2004-06-08 03:16:41 EDT
Similar problem.
Installed FC2.
Does not boot. It habgs after selecting FC2 in the GRUB menu and it
prints "boot command list" or something like that. It just hangs there.
Windows boots fine ( from GRUB, "Other" ).

Then I wiped the disk ( cat /dev/zero > /dev/hde ) and installed FC2
with no boot loader. ( I thought it will offer to create a boot-floppy
). Then I booted the CD1 with "linux rescue" run "grub-install /dev/hde",
boted , entered the comands "root (hd0,0)", "kernel /vmlinuz-2.x.x.x"
, "initrd /initrd-x.x.x"  and "boot" and nothing happens, it just
hangs there.

HW :
 - Gigabyte GA7-VAXP Ultra ( VIA KT400 ) , BIOS version F6
 - hde is a Quantum 20GB on the on board Promise PDC 20276 ( BIOS is
set to RAID mode, due to some M$ problems with straight ATA mode ... )
Comment 3 mike 2004-06-09 05:47:05 EDT
After install and reboot winxp boots without grub even coming up.
winxp is on hda1 and fc2 is on hda2. I see this has been a problem for
years with grub, why not have a floppy option or lilo to correct this?
Comment 4 David Balažic 2004-06-09 07:17:26 EDT
For my problem I opened bug 125607
Comment 5 Mihnea Galca 2004-06-10 15:11:23 EDT
I've managed to boot fedora. The problem was caused by the fact that
grub couldn't read grud.conf file, because it was placed on a high
cylinder.
Probably when I've installed rh8,rh9 a long time ago, the grub.conf
file was placed with a bit of luck in the first cylinders of the hard
disk and I couldn't encounter this problem.

I've reinstalled fc2 using the following partitioning scheme:
/dev/hdb1 /boot 100Mb ext3
/dev/hdb2 swap 512Mb swap
/dev/hdb3 / 9Gb ext3
and everything worked aftwards.

Note You need to log in before you can comment on or make changes to this bug.