Bug 1254570 - ceph-deploy does not work with multiple nodes with --repo on ubuntu
ceph-deploy does not work with multiple nodes with --repo on ubuntu
Status: CLOSED WONTFIX
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Installer (Show other bugs)
1.2.3
x86_64 Linux
unspecified Severity unspecified
: rc
: 1.2.4
Assigned To: Alfredo Deza
ceph-qe-bugs
:
: 1198326 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-18 08:16 EDT by rakesh
Modified: 2015-12-08 11:44 EST (History)
9 users (show)

See Also:
Fixed In Version: ceph-deploy-1.5.22.4-1.el7cp ceph-deploy-1.5.22.4-1.el6cp
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-08 11:44:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rakesh 2015-08-18 08:16:54 EDT
Description of problem:

This is for the ceph version 1.2.3 on ubuntu 14.04 
 
when we run ceph-deploy install --repo node1 node2 node3 node4 on a fresh system, ceph-deploy works only on the first node given and does not consider on all remaing nodes. we will have to run ceph-deploy for each node separately.  

this command comes under the section "Installing ceph" : 
 https://gitlab.cee.redhat.com/ngoswami/red-hat-ceph-storage-installation-guide-ubuntu/blob/v1.2.3/quick-ceph-deploy.adoc

This has to be documented or changed in the code.
Comment 2 Alfredo Deza 2015-08-18 10:36:27 EDT
rakesh would you mind showing some output of this behavior?
Comment 4 Alfredo Deza 2015-08-18 11:06:27 EDT
I just tried with 1.5.23 and it worked as well. Again, please show some output that demonstrates how this is not working so we can troubleshoot better.
Comment 5 John Wilkins 2015-08-18 12:19:30 EDT
Nilam, 

Can you have a look at this?
Comment 7 rakesh 2015-08-19 06:10:03 EDT
I will try to set up the fresh system and provide you will the logs. There may be slight delay in providing the logs as my systems are already upgraded and need to  be re-imaged
Comment 8 Hemanth Kumar 2015-08-26 06:43:41 EDT
This is seen while Installing 1.2.3 on Ubuntu 12.04

Here is the output :- http://pastebin.test.redhat.com/308188
Comment 14 Ken Dreyer (Red Hat) 2015-10-19 13:12:41 EDT
This was fixed by the following patch on upstream's 1.5.22-stable branch:

commit 1dfc7489cf3a333d8631d863205010ef6e0af8a7
Author: Travis Rhoden <trhoden@redhat.com>
Date:   Tue Mar 31 15:56:18 2015 -0400

    [1.5.22-stable] make install --repo handle multiple hosts
    
    The for loop was always returning after the first host
    
    Signed-off-by: Travis Rhoden <trhoden@redhat.com>
    (cherry picked from commit c47f784e3d19dec2fc99ff4d23fe314801d1f2dd)

We would need to cut a 1.5.22.4 ceph-deploy release to ship this.
Comment 15 Ken Dreyer (Red Hat) 2015-10-19 16:22:22 EDT
*** Bug 1198326 has been marked as a duplicate of this bug. ***
Comment 17 Ken Dreyer (Red Hat) 2015-12-08 11:44:36 EST
Closing all RHCS 1.2 bugs, since we are not planning to do a formal RHCS 1.2.4 release.

This particular issue was already fixed in RHCS 1.3, in ceph-deploy v1.5.27.

Note You need to log in before you can comment on or make changes to this bug.