Bug 1254629 - several async tasks are not cleared altough they are over and finished in vdsm
several async tasks are not cleared altough they are over and finished in vdsm
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.5.1
Unspecified Unspecified
unspecified Severity high
: ovirt-3.5.5
: 3.5.5
Assigned To: Idan Shaby
Aharon Canan
storage
: AutomationBlocker, ZStream
Depends On: 1213850
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-18 10:16 EDT by rhev-integ
Modified: 2016-02-10 12:14 EST (History)
13 users (show)

See Also:
Fixed In Version: ovirt-engine-3.5.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1213850
Environment:
Last Closed: 2015-10-26 14:33:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45030 master MERGED core: added missing constructor to RetrieveImageDataCommand Never
oVirt gerrit 45032 ovirt-engine-3.5 MERGED core: added missing constructor to RetrieveImageDataCommand Never

  None (edit)
Comment 1 Yaniv Lavi (Dary) 2015-09-21 07:51:07 EDT
Can you please add steps to reproduce?
Comment 2 Tal Nisan 2015-10-06 09:15:14 EDT
Not an easy reproduction, we had to stop the thread in the middle of the delete operation, restart Jboss in suspend JVM mode and verify it like that.
Basically it can be reproduced (actually not reproduced in that case since the error is fixed) when you shutdown Jboss exactly when the result is returned from VDSM after a disk removal.
I suggest moving to VERIFIED in that case since this is basically more of a code change
Comment 3 Aharon Canan 2015-10-07 10:32:16 EDT
Following comment #2 and since we didn't face it lately with 3.5.5, 
moving to verified.

In case we will reproduce we will reopen it.
Comment 5 errata-xmlrpc 2015-10-26 14:33:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1938.html

Note You need to log in before you can comment on or make changes to this bug.