Bug 1254742 - Several translations not displayed
Several translations not displayed
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-language (Show other bugs)
23
All All
unspecified Severity medium
: ---
: ---
Assigned To: Parag Nemade
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-18 14:34 EDT by Adam Williamson
Modified: 2015-08-26 00:33 EDT (History)
4 users (show)

See Also:
Fixed In Version: 3.2.0-2.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-26 00:33:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2015-08-18 14:34:26 EDT
Doing the F23 l10n Test Day, I noticed that available translations for the window title and buttons in system-config-language do not seem to display. Looking in Zanata, translations are available for the window title ("Language Selection") and the buttons ("Help", "System Defaults", "Cancel", and "OK") in both German and Dutch, but running the app with LANGUAGE=nl_NL.UTF-8 or LANGUAGE=de_DE.UTF-8 does not display these translations. The English labels are used.
Comment 1 Adam Williamson 2015-08-18 15:55:59 EDT
This seems to be because the strings are marked as 'fuzzy' in the .po files . I'm not sure if this is an error or standard.
Comment 2 Parag Nemade 2015-08-19 12:19:30 EDT
It was some coding issue that made them fuzzy few releases ago. Unfortunately no one reported translations issue before. I have fixed the coding issue now. But I found some of the translated strings in some languages are bigger in width now making s-c-l gui window to widen in width.
e.g. in fr.po
#. TRANSLATORS: GUI button to revert the system language to English
#: ../src/language_gui.py:96
msgid "System Defaults"
msgstr "Configuration par défaut du système"


I am going to release fixed tarball 3.2.0 and update this package tomorrow.
Comment 3 Fedora Update System 2015-08-20 02:49:21 EDT
system-config-language-3.2.0-2.fc23 has been submitted as an update to Fedora 23. https://bugzilla.redhat.com/show_bug.cgi?id=1254742
Comment 4 Fedora Update System 2015-08-22 12:25:44 EDT
system-config-language-3.2.0-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update system-config-language'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-13792
Comment 5 Fedora Update System 2015-08-26 00:33:15 EDT
system-config-language-3.2.0-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.