Bug 1254743 - id command not showing all groups
id command not showing all groups
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd (Show other bugs)
7.1
All Linux
unspecified Severity high
: rc
: ---
Assigned To: Lukas Slebodnik
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-18 14:36 EDT by Striker Leggette
Modified: 2016-01-07 11:40 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-07 11:40:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Striker Leggette 2015-08-18 14:36:57 EDT
Description of problem:
 - 'id' command not showing all groups for specific user after adding RHEL client to AD domain using REALMD.

Version-Release number of selected component (if applicable):
 - sssd-1.12.2-58.el7_1.6.x86_64
 - Linux 3.10.0-229.7.2.el7.x86_64 #1 SMP Fri May 15 21:38:46 EDT 2015 x86_64 x86_64 x86_64 GNU/Linux


How reproducible:
 - Always (for this specific user)

Steps to Reproduce:
1. Use realmd to add client to AD.
2. Try to log in to user allowed through simple_allow_groups.

Actual results:
 - Permission denied by sshd:account.

Expected results:
 - User logs in successfully.

Additional info:
 - See private note below.
Comment 5 Jakub Hrozek 2015-08-19 03:58:05 EDT
This looks like a duplicate of rhbz#1227772 please ask the customer to re-test with the latest z-stream packages.
Comment 9 Striker Leggette 2015-08-25 17:07:53 EDT
Customer confirmed the following for RHEL 6:

  # wget https://copr.fedoraproject.org/coprs/lslebodn/sssd-1-12/repo/epel-7/lslebodn-sssd-1-12-epel-7.repo -O /etc/yum.repos.d/lslebodn-sssd-1-12-epel-7.repo
  # yum clean all ; yum update sssd*

The above resolved their issue.
Comment 10 Lukas Slebodnik 2015-08-27 02:46:21 EDT
(In reply to Striker Leggette from comment #9)
> Customer confirmed the following for RHEL 6:
> 
>   # wget
> https://copr.fedoraproject.org/coprs/lslebodn/sssd-1-12/repo/epel-7/lslebodn-
> sssd-1-12-epel-7.repo -O /etc/yum.repos.d/lslebodn-sssd-1-12-epel-7.repo
>   # yum clean all ; yum update sssd*
> 
> The above resolved their issue.

It's good to know it's fixed in upstream.
Some of bugs related to ldb_modify failed was fixed in the latest rhel7 Z-stream.

Could customer retest with rhel supported packages 1.12.2-58.el7_1.14?

Note You need to log in before you can comment on or make changes to this bug.