This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1254883 - RFE: Use GitHub source tarball
RFE: Use GitHub source tarball
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qtsingleapplication (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Raphael Groner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 03:50 EDT by Raphael Groner
Modified: 2015-09-15 09:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-13 12:52:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raphael Groner 2015-08-19 03:50:51 EDT
Description of problem:
Source URL is unreachable currently.

Version-Release number of selected component (if applicable):
-

How reproducible:
yes

Steps to Reproduce:
1. Navigate to Source URL given in spec file.
2.
3.

Actual results:
Error 404

Expected results:
Working download of source tarball from the given URL.

Additional info:
I guess Gitorious is dead in favour of GitLab.
Comment 1 Raphael Groner 2015-08-19 03:51:38 EDT
Replace also local patches with upstream fixes, for Qt5 support.
Comment 2 Raphael Groner 2015-09-13 12:52:35 EDT
Fixed in rawhide.
Comment 3 Fabio Alessandro Locati 2015-09-15 05:22:54 EDT
It seems like this update broke everything that was depending on qtsingleapplication:

qbittorrent has broken dependencies in the rawhide tree:
On x86_64:
        1:qbittorrent-3.2.3-3.fc24.x86_64 requires libQtSolutions_SingleApplication-2.6.so.1()(64bit)
On i386:
        1:qbittorrent-3.2.3-3.fc24.i686 requires libQtSolutions_SingleApplication-2.6.so.1
On armhfp:
        1:qbittorrent-3.2.3-3.fc24.armv7hl requires libQtSolutions_SingleApplication-2.6.so.1
On x86_64:
        1:qbittorrent-nox-3.2.3-3.fc24.x86_64 requires libQtSolutions_SingleCoreApplication-2.6.so.1()(64bit)
On i386:
        1:qbittorrent-nox-3.2.3-3.fc24.i686 requires libQtSolutions_SingleCoreApplication-2.6.so.1
On armhfp:
        1:qbittorrent-nox-3.2.3-3.fc24.armv7hl requires libQtSolutions_SingleCoreApplication-2.6.so.1
Please resolve this as soon as possible.
Comment 4 Raphael Groner 2015-09-15 09:00:30 EDT
(In reply to Fabio Alessandro Locati from comment #3)
http://pkgs.fedoraproject.org/cgit/qtsingleapplication.git/commit/?id=e5c6c64614704e2a0eb587f1b1c632dabea2e294

Note You need to log in before you can comment on or make changes to this bug.