Bug 1254910 - Numa nodes list of VM should be changed only when Vm status is down
Numa nodes list of VM should be changed only when Vm status is down
Status: CLOSED WONTFIX
Product: ovirt-engine
Classification: oVirt
Component: General (Show other bugs)
---
Unspecified Unspecified
high Severity medium (vote)
: ovirt-4.2.0
: ---
Assigned To: bugs@ovirt.org
Artyom
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 04:48 EDT by Tomer Saban
Modified: 2017-07-26 05:04 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-26 05:04:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
rule-engine: planning_ack+
dfediuck: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45644 master ABANDONED core: vNumaNodeList can only be changed on vm down 2016-04-25 18:43 EDT

  None (edit)
Description Tomer Saban 2015-08-19 04:48:46 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Roy Golan 2015-08-30 10:25:34 EDT
Please put a reproducer here.

note: this means that numa nodes list should be exported to ovf as well. 

I think its relatively small but important fix that will allow to have numa info on export/import. Doron?
Comment 2 Tomer Saban 2015-09-06 07:25:08 EDT
Description of problem:
oVirt allows changing pinning of numa nodes even when VM is in status up which is illegal because this changes should only occur when VM is down.

How reproducible:
100%

Steps to Reproduce:
1.Create new VM and run it.
2.On subtab Host->Start Running On: change to specific host with numa support.
3.Migration Options: choose "Do not allow migration"
4.Click Numa Pinning and change something in the numa pinning.

Actual results:
Numa pinning has changed even though the VM is running.

Expected results:
Message should popup saying that the changes will take place only on next reboot.
Comment 3 Doron Fediuck 2015-10-12 08:16:14 EDT
(In reply to Roy Golan from comment #1)
> Please put a reproducer here.
> 
> note: this means that numa nodes list should be exported to ovf as well. 
> 
> I think its relatively small but important fix that will allow to have numa
> info on export/import. Doron?

Roy, how will it influence hosted engine upgrade?
ie- We should prefer 3.6 stabilization now ad this seems to be a non-trivial change.
Comment 4 Red Hat Bugzilla Rules Engine 2015-10-19 06:52:02 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 5 Roy Golan 2015-11-17 04:06:30 EST
(In reply to Doron Fediuck from comment #3)
> (In reply to Roy Golan from comment #1)
> > Please put a reproducer here.
> > 
> > note: this means that numa nodes list should be exported to ovf as well. 
> > 
> > I think its relatively small but important fix that will allow to have numa
> > info on export/import. Doron?
> 
> Roy, how will it influence hosted engine upgrade?
> ie- We should prefer 3.6 stabilization now ad this seems to be a non-trivial
> change.

No direct influence on HE as it doesn't support numa config atm.
Comment 6 Mike McCune 2016-03-28 19:42:22 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 7 Sandro Bonazzola 2016-05-02 05:49:39 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 10 Yaniv Kaul 2016-05-08 07:01:53 EDT
Patch is in Abandoned state - moving back to ASSIGNED.
Comment 11 Yaniv Lavi 2016-05-23 09:13:53 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 12 Martin Sivák 2016-11-28 09:32:38 EST
Nobody is working on this atm. Moving to the next release.
Comment 13 Yaniv Kaul 2016-11-28 09:36:30 EST
(In reply to Martin Sivák from comment #12)
> Nobody is working on this atm. Moving to the next release.

The next release is 4.1. But realistically, this should go to 4.2 or closed.
Comment 14 Martin Sivák 2016-11-28 09:39:43 EST
You are right, it might be better to mark it for reevaluation then. We will decide on this bug's faith with Moran.
Comment 15 Doron Fediuck 2017-07-26 05:04:04 EDT
We won't be perusing this issue any more. If someone needs it, patches are welcomed.

Note You need to log in before you can comment on or make changes to this bug.