Bug 1254939 - [hosted-engine] can't install ovirt-hosted-engine-setup because glusterfs-cli is low version
[hosted-engine] can't install ovirt-hosted-engine-setup because glusterfs-cli...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup (Show other bugs)
3.6.0
Unspecified Linux
unspecified Severity urgent
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Sandro Bonazzola
Nikolai Sednev
: Triaged
: 1254495 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 05:37 EDT by Jiri Belka
Modified: 2016-03-11 02:33 EST (History)
5 users (show)

See Also:
Fixed In Version: ovirt-hosted-engine-setup-1.3.0-0.4.beta.git42eb801.el7ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-11 02:33:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Belka 2015-08-19 05:37:07 EDT
Description of problem:
can't install ovirt-hosted-engine-setup because glusterfs-cli is low version.

--> Finished Dependency Resolution
Error: Package: ovirt-hosted-engine-setup-1.3.0-0.3.beta.git42eb801.el7ev.noarch (rhev-master)
           Requires: glusterfs-cli >= 3.7.2
           Available: glusterfs-cli-3.7.1-11.el7.x86_64 (rhel-72-optional)
               glusterfs-cli = 3.7.1-11.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@dell-r210ii-13 ~]# yum repolist -v | grep Server-optional
Repo-baseurl : http://download.englab.brq.redhat.com/pub/rhel/nightly/RHEL-7.2-20150817.n.2/compose/Server-optional/x86_64/os/

somebody has to ask if Server-optional will contain 3.7.1* or 3.7.2* in the future.

Version-Release number of selected component (if applicable):
rhevm 3.6.0-9 d/s

How reproducible:
100%

Steps to Reproduce:
1. yum install ovirt-hosted-engine-setup
2.
3.

Actual results:
bad deps - glusterfs-cli version too low

Expected results:
should work

Additional info:

wrkaround: http://download.gluster.org/pub/gluster/glusterfs/LATEST/EPEL.repo/epel-7Server/x86_64/

# yum repolist -v | grep baseurl
Repo-baseurl : http://download.eng.brq.redhat.com/pub/rhel/released/JBEAP-6/6.4.2/composes/JBEAP-6.4.2-RHEL-7/Server/x86_64/os
Repo-baseurl : http://download.englab.brq.redhat.com/pub/rhel/nightly/RHEL-7.2-20150817.n.2/compose/Server/x86_64/os/
Repo-baseurl : http://download.englab.brq.redhat.com/pub/rhel/nightly/RHEL-7.2-20150817.n.2/compose/Server-optional/x86_64/os/
Repo-baseurl : http://download.lab.bos.redhat.com/rel-eng/repos/rhevh-rhel-7.2-candidate/x86_64/
Repo-baseurl : http://10.34.63.204/builds/3.6/3.6.0-9/el7Server
Repo-baseurl : http://10.34.63.204/repo-tlv-builds/latest_vt/el7
Comment 1 Sandro Bonazzola 2015-08-19 07:40:29 EDT
*** Bug 1254495 has been marked as a duplicate of this bug. ***
Comment 2 Sandro Bonazzola 2015-08-19 07:44:04 EDT
Dependency has been already lowered in latest build available in brew.
Comment 3 Nikolai Sednev 2015-08-31 08:20:14 EDT
Now HE installation succeeds on these components:

Host:
mom-0.5.0-1.el7ev.noarch
sanlock-3.2.4-1.el7.x86_64
libvirt-client-1.2.17-6.el7.x86_64
qemu-kvm-rhev-2.3.0-19.el7.x86_64
ovirt-vmconsole-1.0.0-0.0.master.el7ev.noarch
ovirt-vmconsole-host-1.0.0-0.0.master.el7ev.noarch
vdsm-4.17.3-1.el7ev.noarch
Linux version 3.10.0-306.0.1.el7.x86_64 (mockbuild@x86-024.build.eng.bos.redhat.com) (gcc version 4.8.3 20140911 (Red Hat 4.8.3-9) (GCC) ) #1 SMP Wed Aug 19 16:06:58 EDT 2015

Note You need to log in before you can comment on or make changes to this bug.