Bug 125497 - Programs build with actual gettext are linked against "libintl.so.3"
Programs build with actual gettext are linked against "libintl.so.3"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gettext (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Leon Ho
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-08 02:36 EDT by Robert Scheck
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-09 20:11:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-06-08 02:36:57 EDT
Description of problem:
At first, I don't really know whether this is a bug or a feature ;-)

I built the latest gettext and installed it (including gettext-
devel). Now, all new rebuilded programs/applications (in my example below, php) are linked now against "libintl.so.3" - why and is this 
really needed? So the older applications/programs aren't linked 
against "libintl.so.3" and work, too...

--- snipp ---
# ldd /usr/bin/php | grep intl
        libintl.so.3 => /usr/lib/libintl.so.3 (0x400fd000)
# 
--- snapp ---

Version-Release number of selected component (if applicable):
>= gettext-0.14.1-3

How reproducible & Steps to Reproduce:
Everytime, see above.
  
Actual results:
Why are the applications linked against libintl.so.3 and is this
really needed - so we lived without that good, before... ;-)

Could you please check, whether that new behaviour is really 
correct? Thank you :)

Expected results:
Veryfication and resulting answer...

Additional info:
If that linking is a stupid behaviour please remove that "feature"
immediately. Thank you.
Comment 1 Robert Scheck 2004-06-08 02:55:33 EDT
If I'm not wrong and I read & understood the changelog correctly, 
that "feature" of "libintl.so.3" was already removed in 2001:

- 0.10.40 - libintl is now LGPLed (it was GPLed). Note that RHL
  uses the glibc version, and don't include libintl from gettext.

and this would match with the introduced and up to gettext-0.14.1-2.1
existing "rm -f $RPM_BUILD_ROOT%{_libdir}/{libintl.a,libintl.la}" in
the spec file.

But I'm also not sure.
Comment 2 Leon Ho 2004-06-08 08:47:52 EDT
Thanks for your testing on gettext.

libintl.so is 'back' because after 0.14.1-2.1 we have enabled shared
libraries. Before it was not affect other application as libintl is
staticly linked to gettext and also removed static libs.

So for now I used --without-included-gettext to avoid the need of
libintl.so and also remove preloadable_libintl.so.

Would you able to test 0.14.1-6 in rawhide if possible? Thanks!
Comment 3 Robert Scheck 2004-06-09 11:23:02 EDT
Leon, thanks you very much for your great work:

--- snipp ---
# ldd /usr/bin/php | grep intl
#
--- snapp ---

Now it is fixed for me...
Comment 4 Reuben Farrelly 2004-06-20 08:06:10 EDT
I must have missed something here:

[root@tornado fedora]# rpm -q php
php-4.3.7-1
[root@tornado fedora]# rpm -q gettext
gettext-0.14.1-7
[root@tornado fedora]# /usr/bin/php -v
/usr/bin/php: error while loading shared libraries: libintl.so.3: 
cannot open shared object file: No such file or directory
[root@tornado fedora]# 
[root@tornado fedora]# ldd /usr/bin/php | grep intl
        libintl.so.3 => not found
[root@tornado fedora]# 

Still seems broken?
Comment 5 Robert Scheck 2004-06-20 08:30:54 EDT
It isn't really broken, but php-4.3.7 only needs urgently a rebuild 
against the current gettext to fix this issue, I'll write a mail to Joe 
Orton, the maintainer of this package.
Comment 6 Leon Ho 2004-06-20 09:58:59 EDT
I have contacted Joe a while ago and php will be rebuilt soon.

Note You need to log in before you can comment on or make changes to this bug.