Bug 1254983 - Failed on update stack when scaling controllers
Failed on update stack when scaling controllers
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Linux
medium Severity urgent
: y2
: 7.0 (Kilo)
Assigned To: chris alfonso
yeylon@redhat.com
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 07:32 EDT by Ola Pavlenko
Modified: 2016-04-18 03:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-26 12:42:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
deployController.log (5.17 MB, text/plain)
2015-08-19 07:32 EDT, Ola Pavlenko
no flags Details

  None (edit)
Description Ola Pavlenko 2015-08-19 07:32:40 EDT
Created attachment 1064764 [details]
deployController.log

Description of problem:
Stack update failes with 
Resource failed - Unknown status FAILED due to "ResourceUnknownStatus: Resource failed - Unknown status FAILED due to "Error: Deployment to server failed: deploy_status_code : Deployment exited with non-zero status code: 6"" |

for ControllerNodesPostDeployment resource while scaling controllers.

Version-Release number of selected component (if applicable):
python-rdomanager-oscplugin-0.0.8-44.el7ost.noarch

How reproducible:
always

Steps to Reproduce:
All steps are done via CLI
1.deploy overcloud with 1 controller, one compute and 1 ceph using command: 
openstack overcloud deploy --ceph-storage-scale 1  --templates templates/openstack-tripleo-heat-templates/ -e templates/openstack-tripleo-heat-templates/environments/storage-environment.yaml --debug &> deployNew.log
2. Scale compute nodes from 1 to 3:
openstack overcloud deploy --ceph-storage-scale 1  --compute-scale 3 --templates templates/openstack-tripleo-heat-templates/ -e templates/openstack-tripleo-heat-templates/environments/storage-environment.yaml --debug &> deployCompute.log

3. Change stack: scale controllers from 1 to 3 (downscale compute nodes to 1 ):
openstack overcloud deploy --ceph-storage-scale 1  --control-scale 3 --templates templates/openstack-tripleo-heat-templates/ -e templates/openstack-tripleo-heat-templates/environments/storage-environment.yaml --debug &> deployController.log

Actual results:
1. Successfully deployed
2. Successfully scaled compute nodes
3. Failed with Resource failed - Unknown status FAILED due to "ResourceUnknownStatus: Resource failed - Unknown status FAILED due to "Error: Deployment to server failed: deploy_status_code : Deployment exited with non-zero status code: 6""  for ControllerNodesPostDeployment resource.

Expected results:
1. Successfully deployed
2. Successfully scaled compute nodes
3. Successfully scaled  controller

Additional info:
deployController.log is attached.
$ heat resource-show overcloud ControllerNodesPostDeployment
+------------------------+---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+
| Property               | Value                                                                                                                                                                                                                                                   |
+------------------------+---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+
| attributes             | {}                                                                                                                                                                                                                                                      |
| description            |                                                                                                                                                                                                                                                         |
| links                  | http://192.0.2.1:8004/v1/31b931dab91c48e39115f38dc13dae2a/stacks/overcloud/ab3d4fe4-8494-494b-b861-0f8fe66cc15e/resources/ControllerNodesPostDeployment (self)                                                                                          |
|                        | http://192.0.2.1:8004/v1/31b931dab91c48e39115f38dc13dae2a/stacks/overcloud/ab3d4fe4-8494-494b-b861-0f8fe66cc15e (stack)                                                                                                                                 |
|                        | http://192.0.2.1:8004/v1/31b931dab91c48e39115f38dc13dae2a/stacks/overcloud-ControllerNodesPostDeployment-vs4js7zgaszk/fe90cd3f-ba9f-4b1a-b91d-4c01cc5cb34c (nested)                                                                                     |
| logical_resource_id    | ControllerNodesPostDeployment                                                                                                                                                                                                                           |
| physical_resource_id   | fe90cd3f-ba9f-4b1a-b91d-4c01cc5cb34c                                                                                                                                                                                                                    |
| required_by            | BlockStorageNodesPostDeployment                                                                                                                                                                                                                         |
|                        | CephStorageNodesPostDeployment                                                                                                                                                                                                                          |
| resource_name          | ControllerNodesPostDeployment                                                                                                                                                                                                                           |
| resource_status        | UPDATE_FAILED                                                                                                                                                                                                                                           |
| resource_status_reason | ResourceUnknownStatus: Resource failed - Unknown status FAILED due to "ResourceUnknownStatus: Resource failed - Unknown status FAILED due to "Error: Deployment to server failed: deploy_status_code : Deployment exited with non-zero status code: 6"" |
| resource_type          | OS::TripleO::ControllerPostDeployment                                                                                                                                                                                                                   |
| updated_time           | 2015-08-19T09:38:48Z                                                                                                                                                                                                                                    |
+------------------------+---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+


env: lynx02.qa.lab.tlv.redhat.com | qum10net
virt: root@192.168.122.32
Comment 3 chris alfonso 2015-08-26 12:42:56 EDT
We don't currently support scaling of controllers.

Note You need to log in before you can comment on or make changes to this bug.