Bug 1255005 - Performance issues in the web ui accessing repo related pages
Performance issues in the web ui accessing repo related pages
Status: CLOSED DUPLICATE of bug 1265884
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Performance (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity high (vote)
: GA
: --
Assigned To: Chris Duryee
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 08:18 EDT by Fred van Zwieten
Modified: 2017-04-25 12:17 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-30 19:19:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 11561 None None None 2016-04-26 12:59 EDT

  None (edit)
Description Fred van Zwieten 2015-08-19 08:18:23 EDT
Description of problem:
In satellite 6.1.1 we experience very noticable slowdown in the responsiveness of the web ui at various points in the web ui. It seems to be primarily related to the katello bits and within that it seems to be whenever repositories are involved in the query.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
A user interface must be responsive. Tasks take time is ok. That is why there is a task engine. Tasks like repo sync, publish, promote take time. However building up a web page should be as snappy as in satellite 5. Examples are rendering the products page, rendering the repository page of a product when there are around 10 repositories, building up the list of content hosts. If you look at the information that is on the page and must be retrieved from the database, the query that must retrieve that data takes up way to much time.
Comment 2 Bryan Kearney 2015-08-25 14:54:34 EDT
Created redmine issue http://projects.theforeman.org/issues/11561 from this bug
Comment 3 Bryan Kearney 2015-08-26 15:21:29 EDT
Upstream bug component is WebUI
Comment 4 Justin Sherrill 2015-09-01 14:51:26 EDT
This is likely a dupe of https://bugzilla.redhat.com/show_bug.cgi?id=1253802 which is scheduled to go out in the next 6.1.z errata.

The number one source of the performance issue was viewing repositories when their product was associated to a sync plan.  So an easy way to know if 1253802's fix will resolve your issue is if you remove the products from their sync plan and you see performance improve quite a bit.  

I saw we wait until that errata goes out and if this is still present we investigate again, ideally with user data
Comment 6 Bryan Kearney 2016-02-02 02:08:51 EST
Upstream bug component is WebUI
Comment 7 Bryan Kearney 2016-02-05 14:09:00 EST
Upstream bug component is WebUI
Comment 9 Mike McCune 2016-05-17 01:38:47 EDT
re-assigning to Adam who is working performance stuff for 6.2
Comment 10 Chris Duryee 2016-05-30 19:19:15 EDT
Some areas this bug mentions have already been addressed, but I believe all portions will be addressed once https://bugzilla.redhat.com/show_bug.cgi?id=1265884 is merged.

Marking this bug as a duplicate of that BZ, since that is the last remaining area of this BZ that needs attention.

*** This bug has been marked as a duplicate of bug 1265884 ***

Note You need to log in before you can comment on or make changes to this bug.