Bug 125501 - pppd segfaults when ms-chap is in use on AMD64
pppd segfaults when ms-chap is in use on AMD64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ppp (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
http://marc.theaimsgroup.com/?l=linux...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-08 05:05 EDT by Oleg Makarenko
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-21 06:59:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oleg Makarenko 2004-06-08 05:05:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
pppd segfaults with signal 11 when ms-chap authentication is used.

The problem is with sha1.c file that assumes that unsigned long is 32-
bits wide (on AMD64 in is 64-bits wide).

Possible solutions are:

1. get rid of sha1.c and use openssl's sha implementation. that 
requires some trivial pppd patching

or 

2. Patch sha1.c to use int32 instead of unsigned long (for example as 
in

http://marc.theaimsgroup.com/?l=linux-ppp&m=108667897423901&w=2
)

I would prefer to link in libcrypto.


Version-Release number of selected component (if applicable):
ppp-2.4.2-2

How reproducible:
Always

Steps to Reproduce:
run pppd in ms-chap mode
    

Actual Results:  pppd died with signal 11 message in /var/log/message

Additional info:
Comment 1 Thomas Woerner 2004-06-21 06:59:05 EDT
Fixed in rawhide in rpm ppp-2.4.2-3.1 or newer.

Note You need to log in before you can comment on or make changes to this bug.