Bug 1255011 - [DOCS] More information on secrets with examples
[DOCS] More information on secrets with examples
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.0.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: brice
weiwei jiang
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 08:33 EDT by Jaspreet Kaur
Modified: 2016-10-30 18:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-29 02:50:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaspreet Kaur 2015-08-19 08:33:52 EDT
Document URL: https://access.redhat.com/documentation/en/openshift-enterprise/version-3.0/openshift-enterprise-30-developer-guide#secrets

Section Number and Name:  Chapter 10.Secrets 

Describe the issue: Only an overview is provided in the documentation about secrets. 

1) If a customer wants to provide some custom username, credentials, keys and certificates using to secret to the pod no information is there on it. 

2) How to confirm if the values are correctly set or are being used by the pod should be mentioned in the documentation.



Suggestions for improvement: A complete example would be great for the users to start with rather than disperse information with all the the little points that should be taken care of. 

Additional information:
Comment 1 Jaspreet Kaur 2015-09-29 08:40:38 EDT
Hello,

Inaddition to the above, One can refer below article as an example :

https://access.redhat.com/solutions/1582603

Regards,
Jaspreet
Comment 4 brice 2016-07-29 02:50:15 EDT
Jaspreet has confirmed that the information has been put into the docs since opening this BZ:

https://docs.openshift.com/enterprise/3.2/dev_guide/secrets.html

Closing this as CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.