Bug 1255036 - yum update fails due to php-magickwand needing libMagick libraries
yum update fails due to php-magickwand needing libMagick libraries
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: php-magickwand (Show other bugs)
el6
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 09:23 EDT by Daniel Souvignier
Modified: 2015-08-20 03:07 EDT (History)
2 users (show)

See Also:
Fixed In Version: php-magickwand-1.0.9-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-19 18:43:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Souvignier 2015-08-19 09:23:29 EDT
Description of problem:
When trying yum update on CentOS 6.7, I get a dependency error saying that php-magickwand needs libMagickCore.so.2 and libMagickWand.so.2 which aren't included anymore in ImageMagick 6.7 provided by CentOS 6.7 base. Solution would be to rebuild php-magickwand against the new ImageMagick, I guess.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Do yum update on a CentOS 6.7 with php-magickwand installed

Actual results:
---> Package ImageMagick.x86_64 0:6.5.4.7-7.el6_5 will be updated
--> Processing Dependency: libMagickCore.so.2()(64bit) for package: php-magickwand-1.0.9-1.el6.x86_64
--> Processing Dependency: libMagickWand.so.2()(64bit) for package: php-magickwand-1.0.9-1.el6.x86_64
---> Package ImageMagick.x86_64 0:6.7.2.7-2.el6 will be an update
--> Processing Dependency: libwmf-0.2.so.7()(64bit) for package: ImageMagick-6.7.2.7-2.el6.x86_64
---> Package pam.x86_64 0:1.1.1-20.el6 will be updated
---> Package pam.x86_64 0:1.1.1-20.el6_7.1 will be an update
---> Package sqlite.x86_64 0:3.6.20-1.el6 will be updated
---> Package sqlite.x86_64 0:3.6.20-1.el6_7.2 will be an update
---> Package subversion.x86_64 0:1.6.11-14.el6 will be updated
---> Package subversion.x86_64 0:1.6.11-15.el6_7 will be an update
--> Running transaction check
---> Package ImageMagick.x86_64 0:6.5.4.7-7.el6_5 will be updated
--> Processing Dependency: libMagickCore.so.2()(64bit) for package: php-magickwand-1.0.9-1.el6.x86_64
--> Processing Dependency: libMagickWand.so.2()(64bit) for package: php-magickwand-1.0.9-1.el6.x86_64
---> Package libwmf.x86_64 0:0.2.8.4-23.el6 will be installed
--> Finished Dependency Resolution
Error: Package: php-magickwand-1.0.9-1.el6.x86_64 (@distri_centos64_x64)
           Requires: libMagickCore.so.2()(64bit)
           Removing: ImageMagick-6.5.4.7-7.el6_5.x86_64 (@centos_65_x64)
               libMagickCore.so.2()(64bit)
           Updated By: ImageMagick-6.7.2.7-2.el6.x86_64 (base)
               Not found
Error: Package: php-magickwand-1.0.9-1.el6.x86_64 (@distri_centos64_x64)
           Requires: libMagickWand.so.2()(64bit)
           Removing: ImageMagick-6.5.4.7-7.el6_5.x86_64 (@centos_65_x64)
               libMagickWand.so.2()(64bit)
           Updated By: ImageMagick-6.7.2.7-2.el6.x86_64 (base)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Please help with this, we do need ImageMagick on our web servers, with this problem we can't update our servers.
Comment 1 Anssi Johansson 2015-08-19 09:32:52 EDT
php-magickwand-1.0.9-2.el6 should have this issue fixed. 

https://admin.fedoraproject.org/updates/FEDORA-EPEL-2015-7496/php-magickwand-1.0.9-2.el6

Make sure you have the EPEL repo enabled. Note that your previous php-magickwand seems to have come from a repo named distri_centos64_x64. If that is some sort of an internal repository, make sure your internal repository is up to date. If that repository is provided by your ISP, complain to your ISP.
Comment 2 Daniel Souvignier 2015-08-19 09:38:45 EDT
Thanks for the update. I just learned that our internal mirror isn't up to date yet. I requested to sync it and will report back once the problem is solved.
Comment 3 Daniel Souvignier 2015-08-20 03:07:46 EDT
Our mirrors finished syncing over night, so I was able to update our servers today. Thanks for the help!

Note You need to log in before you can comment on or make changes to this bug.