Bug 1255044 - [RFE] Use CFME REST APIs opposed to mechanize web scraping
[RFE] Use CFME REST APIs opposed to mechanize web scraping
Status: CLOSED CURRENTRELEASE
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - CloudForms (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 1.0
Assigned To: Jason Montleon
Dan Macpherson
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 09:34 EDT by John Matthews
Modified: 2016-04-29 12:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-15 15:37:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Matthews 2015-08-19 09:34:41 EDT
Description of problem:

This RFE tracks the desire to move to using CFME REST APIs opposed to mechanize for adding RHEV provider and credentials for the RHEV Hypervisors.

RHCI developers were unable to use the REST API at time of original development since the REST API did not support the needed calls for adding RHEV.  Since then work has been completed upstream to add the APIs.  We need to revisit this when schedule allows and we can test against downstream builds.
Comment 1 John Matthews 2016-02-15 15:37:28 EST
This is an implementation detail of the CFME flow which was addressed in TP-2.

Note You need to log in before you can comment on or make changes to this bug.