Bug 1255081 - [RFE]: RHEV deployments should install rhevm-dwh and rhevm-reports
[RFE]: RHEV deployments should install rhevm-dwh and rhevm-reports
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - RHEV (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity medium
: ga
: 1.0
Assigned To: Fabian von Feilitzsch
Tasos Papaioannou
Dan Macpherson
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 10:52 EDT by Dave Johnson
Modified: 2016-09-13 12:21 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:21:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1862 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.0 2016-09-13 16:18:48 EDT

  None (edit)
Description Dave Johnson 2015-08-19 10:52:23 EDT
Description of problem:
======================================
In order to collect and view performance metrics from RHEV assets, the installer should be installing and configuring rhevm-dwh and rhevm-reports.  rhevm-dwh is needed by CloudForms to collect and aggregate metrics from RHEV.


Version-Release number of selected component (if applicable):
======================================
08-12 ISO
Comment 1 Fabian von Feilitzsch 2016-01-29 11:08:03 EST
WIP PR up here: https://gitlab.sat.lab.tlv.redhat.com/rhci/puppet-ovirt/merge_requests/9
Comment 3 Tasos Papaioannou 2016-03-28 10:58:12 EDT
The rhevm-dwh and rhevm-reports packages aren't getting installed on the deployed rhevm system:

****
# rpm -q rhevm-dwh rhevm-reports
package rhevm-dwh is not installed
package rhevm-reports is not installed

# cat /var/log/ovirt-engine/setup/ovirt-engine-setup-20160325213027-4gneqn.log
[...]
2016-03-25 21:30:32 DEBUG otopi.plugins.ovirt_engine_setup.rhevm_setup_plugins.distro-rhel.reports plugin.executeRaw:824 execute: ('/bin/rpm', '-q', 'rhevm-dwh'), executable='None', cwd='None', env=None
2016-03-25 21:30:32 DEBUG otopi.plugins.ovirt_engine_setup.rhevm_setup_plugins.distro-rhel.reports plugin.executeRaw:874 execute-result: ('/bin/rpm', '-q', 'rhevm-dwh'), rc=1
2016-03-25 21:30:32 DEBUG otopi.plugins.ovirt_engine_setup.rhevm_setup_plugins.distro-rhel.reports plugin.execute:932 execute-output: ('/bin/rpm', '-q', 'rhevm-dwh') stdout:
package rhevm-dwh is not installed

2016-03-25 21:30:32 DEBUG otopi.plugins.ovirt_engine_setup.rhevm_setup_plugins.distro-rhel.reports plugin.execute:937 execute-output: ('/bin/rpm', '-q', 'rhevm-dwh') stderr:


2016-03-25 21:30:32 DEBUG otopi.plugins.ovirt_engine_setup.rhevm_setup_plugins.distro-rhel.reports plugin.executeRaw:824 execute: ('/bin/rpm', '-q', 'rhevm-reports'), executable='None', cwd='None', env=None
2016-03-25 21:30:32 DEBUG otopi.plugins.ovirt_engine_setup.rhevm_setup_plugins.distro-rhel.reports plugin.executeRaw:874 execute-result: ('/bin/rpm', '-q', 'rhevm-reports'), rc=1
2016-03-25 21:30:32 DEBUG otopi.plugins.ovirt_engine_setup.rhevm_setup_plugins.distro-rhel.reports plugin.execute:932 execute-output: ('/bin/rpm', '-q', 'rhevm-reports') stdout:
package rhevm-reports is not installed

2016-03-25 21:30:32 DEBUG otopi.plugins.ovirt_engine_setup.rhevm_setup_plugins.distro-rhel.reports plugin.execute:937 execute-output: ('/bin/rpm', '-q', 'rhevm-reports') stderr:
[...]
****

It looks like the ovirt-puppet package on the Satellite does not have the commit:

****
# rpm -q ovirt-puppet
ovirt-puppet-0.0.1-20.el7.noarch

# rpm -q --changelog ovirt-puppet | head
* Fri Jan 22 2016 Jason Montleon <jmontleo@redhat.com> 0.0.1-20
- 1263797 - cpu is created and updated to avoid no object being set
  (dymurray@redhat.com)
- If cpu is not defined we now set it and update the cluster
  (dymurray@redhat.com)
- 1263797 - Cluster CPU type is updated regardless of cluster name
  (dymurray@redhat.com)

* Thu Aug 06 2015 Jason Montleon <jmontleo@redhat.com> 0.0.1-19
- catch exceptions so we don't trigger abrt in the event of bad input

# rpm -ql ovirt-puppet
/usr/share/ovirt-puppet/pkg
/usr/share/ovirt-puppet/pkg/jcannon-ovirt-0.0.4.tar.gz

# ll /usr/share/ovirt-puppet/pkg/jcannon-ovirt-0.0.4.tar.gz
-rw-r--r--. 1 root root 12151 Jan 22 12:19 /usr/share/ovirt-puppet/pkg/jcannon-ovirt-0.0.4.tar.gz

# tar xf /usr/share/ovirt-puppet/pkg/jcannon-ovirt-0.0.4.tar.gz jcannon-ovirt-0.0.4/manifests/engine/packages.pp
# cat jcannon-ovirt-0.0.4/manifests/engine/packages.pp 
class ovirt::engine::packages {
	require ovirt
#	require ovirt::repo
	notify {"oVirt Package installation stage- Done":}
	if $ovirt::product == 'oVirt'{
		package { 'ovirt-engine':
			ensure  => installed,
			allow_virtual => false,
#			require => Package[$ovirt::repo::ovirt_release],
		}
	}
	elsif $ovirt::product == 'RHEV'{
		package { 'rhevm':
	                ensure  => installed,
			allow_virtual => false,
#       	        require => Yumrepo['rhevm'],
		}
	}

}
****

Tested on QCI-1.0-RHEL-7-20160315.t.1 and QCI-1.0-RHEL-7-20160323.t.0.
Comment 4 John Matthews 2016-06-03 14:48:30 EDT
Please test with the 1.2 compose from 6/2/2016 or newer.
Comment 5 Tasos Papaioannou 2016-06-22 16:07:38 EDT
Verified on QCI-1.2-RHEL-7-20160621.t.0.
Comment 11 errata-xmlrpc 2016-09-13 12:21:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.