Bug 1255119 - [RFE] set history database credentials
[RFE] set history database credentials
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - RHEV (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity high
: ga
: 1.0
Assigned To: Fabian von Feilitzsch
James Olin Oden
Dan Macpherson
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 13:02 EDT by Dave Johnson
Modified: 2016-09-13 12:21 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:21:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Johnson 2015-08-19 13:02:10 EDT
Description of problem:
======================================
In order for CloudForms to collect performance metrics from the RHEV deployment, CF needs credentials for RHEV's history database. We ultimately should have the installer prompt for, set, and configure CF with these credentials during the deployment.  

This BZ requires bug 1255081 however


Version-Release number of selected component (if applicable):
=======================================
0812 iso


How reproducible:
===================
100%
Comment 1 Fabian von Feilitzsch 2016-07-11 15:47:10 EDT
PR adds RHEV database credentials to CFME

https://github.com/fusor/fusor/pull/995
Comment 2 John Matthews 2016-07-18 17:07:08 EDT
QCI-1.2-RHEL-7-20160718.t.0
Comment 7 James Olin Oden 2016-08-11 13:08:29 EDT
Verified on QCI-1.0-RHEL-7-20160809.t.0

Ran the query:

psql -d vmdb_production -c "select * from authentications where authtype = 'metrics';"

On the CFME VM as root.   Got the following output:

          id       |                           name                           | auth
    type |        userid        |           password            |  resource_id  |  
     resource_type    |         created_on         |         updated_on         |  
        last_valid_on       | last_invalid_on |   credentials_changed_on   | status
    | status_details |        type        | auth_key | fingerprint | service_account
     | challenge | login | public_key | htpassd_users | ldap_id | ldap_email | ldap_
    name | ldap_preferred_user_name | ldap_bind_dn | ldap_insecure | ldap_url | requ
    est_header_challenge_url | request_header_login_url | request_header_headers | r
    equest_header_preferred_username_headers | request_header_name_headers | request
    _header_email_headers | open_id_sub_claim | open_id_user_info | open_id_authoriz
    ation_endpoint | open_id_token_endpoint | open_id_extra_scopes | open_id_extra_a
    uthorize_parameters | certificate_authority | google_hosted_domain | github_orga
    nizations | rhsm_sku | rhsm_pool_id | rhsm_server
    ---------------+----------------------------------------------------------+-----
    -----+----------------------+-------------------------------+---------------+---
    ------------------+----------------------------+----------------------------+---
    ------------------------+-----------------+----------------------------+--------
    +----------------+--------------------+----------+-------------+----------------
    -+-----------+-------+------------+---------------+---------+------------+------
    -----+--------------------------+--------------+---------------+----------+-----
    -------------------------+--------------------------+------------------------+--
    -----------------------------------------+-----------------------------+--------
    ----------------------+-------------------+-------------------+-----------------
    ---------------+------------------------+----------------------+----------------
    --------------------+-----------------------+----------------------+------------
    ----------+----------+--------------+-------------
     1000000000002 | ManageIQ::Providers::Redhat::InfraManager purgatory-RHEV | metr
    ics  | ovirt_engine_history | v2:{mna2LHZAUBqFgw2j+hDQMg==} | 1000000000001 | Ex
    tManagementSystem | 2016-08-10 20:14:33.258561 | 2016-08-10 20:14:41.652941 | 20
    16-08-10 20:14:41.64799 |                 | 2016-08-10 20:14:33.258171 | Valid  
    | Ok             | AuthUseridPassword |          |             |                
     |           |       |            | {}            | {}      | {}         | {}  
         | {}                       |              |               |          |    
                             |                          | {}                     | {
    }                                        | {}                          | {}    
                          |                   |                   |                
                   |                        | {}                   |                
                        |                       |                      | {}        
              |          |              |
    (1 row)
Comment 9 errata-xmlrpc 2016-09-13 12:21:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.