Bug 1255232 - FCoE BFS Installation: LUN not handled by device mapper even after discovery through both the ports of the adapter
FCoE BFS Installation: LUN not handled by device mapper even after discovery ...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-blivet (Show other bugs)
7.2
Unspecified Linux
unspecified Severity low
: rc
: ---
Assigned To: blivet-maint-list@redhat.com
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-20 00:22 EDT by Vishnu Kumar
Modified: 2015-09-08 06:51 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-08 06:51:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
LUN discovered as two different disks (88.55 KB, image/png)
2015-08-20 00:22 EDT, Vishnu Kumar
no flags Details
after performing workaround, LUN is handled by multipath (88.70 KB, image/png)
2015-08-20 00:24 EDT, Vishnu Kumar
no flags Details

  None (edit)
Description Vishnu Kumar 2015-08-20 00:22:59 EDT
Created attachment 1065076 [details]
LUN discovered as two different disks

Description of problem:
While performing FCoE BFS installation using dual port adapter(BCM 57810), LUN (LUN ID 0) discovery is successful through both the ports. After discovery, LUN is seen as two different disks and not handled by device mapper

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Configure the server/adapter (dual port) for FCoE BFS
2. Provision the LUN from the storage array
3. Mount the ISO and start the installation and follow the on screen instruction
4. In the Installation Summary screen, Click on Installation Destination
5. In the Installation Destination screen, Click on "Add a disk"
6. Click on "Add FCoE SAN
7. Select the respective port and click on "Add FCoE Disks", repeat the step for the other port as well


Actual results:
LUN gets discovered through both the ports and and not handled by device mapper (multipath)and seen as two different disks. Please see the attachment "LUN-discovery.png"


Expected results:
LUN should get discovered through both the ports and should be handled by device mapper (multipath)

Workaround:
Able to make the device mapper to handle the LUN by again performing the step 6 and step 7. Please see the attachment "lun-handled-by-device-mapper.png"
Comment 1 Vishnu Kumar 2015-08-20 00:24:15 EDT
Created attachment 1065077 [details]
after performing workaround, LUN is handled by multipath
Comment 4 Ben Marzinski 2015-08-20 14:45:31 EDT
I'm going to reassign this to blivet to see what their opinion is on this. 

Blivet folks, if you think that this is happening because multipath isn't doing something correctly, just let me know what it is, and reassign it back.
Comment 5 Brian Lane 2015-08-24 12:49:27 EDT
Please attach the logs from /tmp/*log as individual text/plain attachments to this bug. Grab them after you have repeated steps 6 and 7 so we can see what things look like before and after your workaround.
Comment 6 Vishnu Kumar 2015-09-08 06:51:05 EDT
(In reply to Brian Lane from comment #5)
> Please attach the logs from /tmp/*log as individual text/plain attachments
> to this bug. Grab them after you have repeated steps 6 and 7 so we can see
> what things look like before and after your workaround.

Brian,

I am unable to reproduce this issue. Hence closing it for now. Will re-open the issue with the requested logs if encounter again.

Note You need to log in before you can comment on or make changes to this bug.