Bug 1255264 - [ALL_LANG] Should change the font color of the login error message.
[ALL_LANG] Should change the font color of the login error message.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
x86_64 Linux
medium Severity medium
: ovirt-3.6.0-rc3
: 3.6.0
Assigned To: Greg Sheremeta
Lukas Svaty
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-20 03:10 EDT by Lijun Li
Modified: 2016-04-12 17:25 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-12 17:25:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Should change the font color of the login error message (55.86 KB, image/png)
2015-08-20 03:13 EDT, Lijun Li
no flags Details
auth failed err string visible with Chromium broswer version 43.0.2357.132 Built from source for Fedora release 22 (Twenty Two) (64-bit) (465.58 KB, image/png)
2015-08-21 06:31 EDT, sandeep shedmake
no flags Details
Error on login (31.04 KB, image/png)
2015-11-09 07:47 EST, Lukas Svaty
no flags Details

  None (edit)
Description Lijun Li 2015-08-20 03:10:51 EDT
Description of problem:
Should change the font color of the login error message.

Version-Release number of selected component (if applicable):
3.6.0-0.11.master.el6

How reproducible:
100%

Steps to Reproduce:
1. Login Admin/User portal with incorrect username/password.
2. Check the error message.

Actual results:
The error message font color is dark grey so not clearly to end-user eyes.

Expected results:
Using red or white font color for the error message.

Additional info:
Please see the attached screenshot.
Comment 1 Lijun Li 2015-08-20 03:13:02 EDT
Created attachment 1065126 [details]
Should change the font color of the login error message
Comment 2 sandeep shedmake 2015-08-21 03:23:51 EDT
+1 to Comment 1,

At first glance, I couldn't figure it out the error message string in the error window:

Login failed. Please verify your login information or contact the system administrator.
 

./frontend/webadmin/modules/userportal-gwtp/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties:USER_FAILED_TO_AUTHENTICATE=Login failed. Please verify your login information or contact the system administrator.
Comment 3 sandeep shedmake 2015-08-21 06:31:43 EDT
Created attachment 1065545 [details]
auth failed err string visible with Chromium broswer version 43.0.2357.132 Built from source for Fedora release 22 (Twenty Two) (64-bit)
Comment 4 sandeep shedmake 2015-08-21 06:46:50 EDT
Could reproduce this bz with firefox-39.0-8.fc22.x86_64
Comment 5 Einav Cohen 2015-08-21 15:59:26 EDT
strange - reported issue here looks different than the one reported in bug 1253685, though both were reported on the exact same RHEV web admin version.
Comment 6 Greg Sheremeta 2015-10-07 17:28:02 EDT
I think the problem is the same -- an outdated rcue1. Please upgrade rcue1 to 1.3.0, and re-open if this does not fix the issue.
Comment 7 Greg Sheremeta 2015-10-07 17:32:36 EDT
See [https://bugzilla.redhat.com/attachment.cgi?id=1080829] -- it should look like this with rcue1 1.3.0 installed.
Comment 8 Greg Sheremeta 2015-10-08 14:55:23 EDT
Re-opening, since I decided to make a code change to force rcue1 1.3.0+.
Comment 9 Sandro Bonazzola 2015-10-26 08:35:13 EDT
this is an automated message. oVirt 3.6.0 RC3 has been released and GA is targeted to next week, Nov 4th 2015.
Please review this bug and if not a blocker, please postpone to a later release.
All bugs not postponed on GA release will be automatically re-targeted to

- 3.6.1 if severity >= high
- 4.0 if severity < high
Comment 10 Einav Cohen 2015-11-02 10:49:54 EST
(In reply to Sandro Bonazzola from comment #9)
> this is an automated message. oVirt 3.6.0 RC3 has been released and GA is
> targeted to next week, Nov 4th 2015.
> Please review this bug and if not a blocker, please postpone to a later
> release.
> All bugs not postponed on GA release will be automatically re-targeted to
> 
> - 3.6.1 if severity >= high
> - 4.0 if severity < high

this is downstream-only and should affect / be affected by anything ovirt-related.
Comment 11 Einav Cohen 2015-11-02 10:51:30 EST
Greg - other than the rcue dependency update, no further updates need to be applied, correct? if so - please move the BZ to MODIFIFED. Thanks.
Comment 12 Lukas Svaty 2015-11-09 07:47:06 EST
Failed QA on:

rcue1-1.3.0-1.el6.noarch
rhevm-webadmin-portal-3.6.0.3-0.1.el6.noarch

Tested on:

firefox-38.4.0
google-chrome-stable-46.0.2490.80-1.x86_64
Comment 13 Lukas Svaty 2015-11-09 07:47 EST
Created attachment 1091729 [details]
Error on login

No error message is displayed.
Comment 14 Einav Cohen 2015-11-09 10:19:36 EST
(In reply to Lukas Svaty from comment #13)
> Created attachment 1091729 [details]
> Error on login
> 
> No error message is displayed.

Lukas, it looks like you hit bug 1251003 / bug 1254940 which will be fixed only for 3.6.1. 
Can you please attempt to re-verify, but this time - attempt to fail the login on a non-empty password (e.g. using a non-empty wrong password / correct-but-expired password, etc.)? Thanks.
Comment 15 Lukas Svaty 2015-11-09 10:25:10 EST
Correct, with incorrect credentials correct message is displayed, visible and nice. Thank you

Note You need to log in before you can comment on or make changes to this bug.