Bug 1255296 - [Enhancement] Graphs should take the measurement and data type into consideration
[Enhancement] Graphs should take the measurement and data type into considera...
Status: CLOSED WONTFIX
Product: JBoss Operations Network
Classification: JBoss
Component: UI (Show other bugs)
JON 3.3.2
Unspecified Unspecified
unspecified Severity low
: ---
: JON 3.3.6
Assigned To: Thomas Heute
Mike Foley
:
Depends On: 1255304
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-20 04:49 EDT by bkramer
Modified: 2016-06-20 05:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-02 11:37:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A screen shot that shows negative values in the graph (100.57 KB, image/png)
2015-08-20 04:49 EDT, bkramer
no flags Details

  None (edit)
Description bkramer 2015-08-20 04:49:39 EDT
Created attachment 1065164 [details]
A screen shot that shows negative values in the graph

Description of problem:

When navigating to datasources "Connection Count" metric for EAP 5 in some cases graph will show negative values (from -1.0 up to 1.0) - see attached negativeValueGraph.png. The same will happen even when "Connection Count" is equal to 0. Only when value of this metric is > 0 proper graph values will be shown. 

This happens because JON does not take the measurement and data type into consideration. For example, for a trends ups measurement, the bottom value will never be lower then the minimum value. Therefore, it would make sense that we would start at 0 in this case. The opposite being true for trends down measurements. In those cases, the largest value on the y-axis should be the maximum value for the displayed time period.


Version-Release number of selected component (if applicable):
JBoss ON 3.3.2

How reproducible:
Always

Steps to Reproduce:
1. Start EAP 5, 
2. import EAP instance into JON inventory,
3. navigate to Monitoring page for EAP instance and open "Connection Count" metric graph;
4. Change the period for the graph to 6 months

Actual results:
Graph is shown with negative values on the y-axis although "Connection Count" cannot have negative value. 

Expected results:
Graph does not show negative values but starts from 0 (in this case).

Additional info:

Note You need to log in before you can comment on or make changes to this bug.