Bug 1255313 - Vinagre Choose file dialog does not list SPICE files
Vinagre Choose file dialog does not list SPICE files
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: vinagre (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Marek Kašík
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-20 05:20 EDT by Vaclav Ehrlich
Modified: 2015-09-15 05:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-03 11:57:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vaclav Ehrlich 2015-08-20 05:20:57 EDT
Description of problem:
Vinagre 'Choose the file' dialog filter files with wrong extension as SPICE files.
Instead *.vv  shows *.spice files

Version-Release number of selected component (if applicable):
vinagre-3.14.3-1

How reproducible:
Always

Steps to Reproduce:
1. Create files test_good.vv and test_bad.spice files in your home dir
2. Open Vinagre
3. Click on Remote->Open
4. Filter out Spice files in select box

Actual results:
Only test_bad.spice file is shown

Expected results:
Only test_good.vv file is shown

Additional info:
Comment 2 Matthias Clasen 2015-08-20 13:28:11 EDT
I don't reproduce this here.

First of all, the extension for vnc files, is .vnc, according to /usr/share/mime/application/x-vnc.xml.

Now, if I have test.vnc and test.spice in my home directory, exactly one of them shows up in the vinagre file chooser, depending on what is selected in the filter combo, which seems exactly right:

if I select "Spice", test.spice shows up
if I select "VNC", test.vnc shows up

Can you clarify what you are seeing ?
Comment 3 Marek Kašík 2015-09-03 11:57:44 EDT
*.spice files also exists and are used by Vinagre. The *.vv files are specific to the Virtual Machine Viewer (virt-viewer) and vinagre doesn't support all its features. So this report is wrong.

I'm closing this as notabug.
Comment 4 Vaclav Ehrlich 2015-09-15 05:24:54 EDT
(In reply to Matthias Clasen from comment #2)
> I don't reproduce this here.
> 
> First of all, the extension for vnc files, is .vnc, according to
> /usr/share/mime/application/x-vnc.xml.
> 
> Now, if I have test.vnc and test.spice in my home directory, exactly one of
> them shows up in the vinagre file chooser, depending on what is selected in
> the filter combo, which seems exactly right:
> 
> if I select "Spice", test.spice shows up
> if I select "VNC", test.vnc shows up
> 
> Can you clarify what you are seeing ?

As Marek mentioned, I was testing it with *.vv files which we use in Remote viewer for spice connection.
I thought this file format is widely used, so I expected it in Vinagre too. If *.spice is the right way for Vinagre, this is really not a bug.

Note You need to log in before you can comment on or make changes to this bug.