Bug 125543 - Bad interaction between gnome workspace switcher applet and sawfish
Bad interaction between gnome workspace switcher applet and sawfish
Status: CLOSED DUPLICATE of bug 120652
Product: Fedora
Classification: Fedora
Component: libwnck (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
http://bugzilla.gnome.org/show_bug.cg...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-08 12:38 EDT by Jan "Yenya" Kasprzak
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan "Yenya" Kasprzak 2004-06-08 12:38:40 EDT
Description of problem:
When using Sawfish as GNOME window manager the click to the pager
applet moves to a different workspace, but it also moves windows so
that upper left corner of the screen is at the coordinates you clicked
in the workspace switcher applet. It makes the pager unusable (after
such action there is no way how to move the viewport back and access
the upper left part of screen.

Version-Release number of selected component (if applicable):
gnome-panel-2.6.0-9
libwnck-2.6.0.1-1
sawfish-1.3-3

How reproducible:
100%

Steps to Reproduce:
1. Run GNOME with sawfish window manager
2. open a few windows on different workspaces, possibly maximize
   some of them.
3. click to the pager applet to switch to a different workspace
  
Actual results:
displayed windows are moved towards (and behind) the upper left corner
of the screen.

Expected results:
The position of windows remain the same when workspaces are switched.

Additional info:
This is probably libwnck bug, documented in GNOME bugzilla:
http://bugzilla.gnome.org/show_bug.cgi?id=122086
I have made the RPMs using patch mentioned in the above bugzilla
entry, and it seems to fix the problem. Packages are available at
ftp://ftp.linux.cz/pub/linux/people/jan_kasprzak/libwnck/libwnck-*2.6*
The packages are GPG signed by my RPM-signing GPG key:
1024D/85502760 2004-03-10 Jan "Yenya" Kasprzak (RPM signing key)
<kas@fi.muni.cz>
Comment 1 Mark McLoughlin 2004-07-27 04:16:51 EDT

*** This bug has been marked as a duplicate of 120652 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.