This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1255444 - Unable to launch java web applications. (ASDM, idrac consoles, calculator)
Unable to launch java web applications. (ASDM, idrac consoles, calculator)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: icedtea-web (Show other bugs)
23
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: jiri vanek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-20 11:09 EDT by Joel F
Modified: 2015-08-31 05:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-26 05:06:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Java console output (5.71 KB, text/plain)
2015-08-20 11:09 EDT, Joel F
no flags Details

  None (edit)
Description Joel F 2015-08-20 11:09:34 EDT
Created attachment 1065300 [details]
Java console output

Description of problem:
Java web applications error out with "Fatal: Read Error: Could not read or parse the JNLP file. ..."

Version-Release number of selected component (if applicable):
icedtea-web.x86   1.6-5.fc23

How reproducible:
Always

Steps to Reproduce:
1. Visit http://www-pw.physics.uiowa.edu/das2/javaPlatformTest.jbf.html
2. Use the second test, "Test WebStart with the Calculator."

(Alternatively try start a Cisco ASDM applet, if you have access to one)

Actual results:
Application fails to start, error messages from java console attached below.
Comment 1 jiri vanek 2015-08-26 05:06:32 EDT
Hello, 
Sorry the target applications very poorly written.
Theirs Calculator.jnlp is so badly written that there is nothing I can do with it.

Workaround for you is to download http://www-pw.physics.uiowa.edu/das2/Calculator.jnlp
replace incorrect closing tag of vender by vendor and removing href="Calculator.jnlp".

Then you can locally run javaws  downloaded/Calcualtor.jnlp and it will handle resurces.

Application is working fine like this.

The correct step is to contact  authors of application and tell them to fix thir jnlp. They can not close <vendor> by </vender>. Then the app will work also from browser as you are expecting. (they do nto need to fix/remove href then)

Now you can use this:
#!/bin/sh
a=`mktemp -d`
pushd $a
wget http://www-pw.physics.uiowa.edu/das2/Calculator.jnlp
sed -i s/vender/vendor/ Calculator.jnlp
sed -i "s/href=\"Calculator.jnlp\"//" Calculator.jnlp
javaws  Calculator.jnlp 
rm -rf $a
popd


I will close this as notabug, however if the error from idrac/asdm is different, please open another bug.

I have access to some idracs, but to no cisco ASDM.

I'm more over assuring that idrac is working. If it do not, please, let me know!
Ideally again with full stacktrace and even more ideally with working reproducer

Tahnk you, and sorry for inconvenience.
Comment 2 Joel F 2015-08-29 04:24:06 EDT
After a lot of trial and error it seems as if the ASDM issue was caused by old/incompatible ciphers. IcedTea still reported this as a parsing error though.

Using an old laptop and navigating ASDM to:
Configuration > Device Management > Advanced > SSL Settings
...and removing the RC4-MD5 and enabling AESxxx-SHA1 variants made IcedTea working again.
Comment 3 jiri vanek 2015-08-31 05:11:49 EDT
Thank you for investigations. I should probably tell you that last update of JDK (not ITW) had default disabling of legacy algorithms.  Sorry,

ITW is reporting it as "cannot parse" pecause the underlying https connection  never download target JNLP. So ITW get only "empty file" which it can not parse.

Only in verbose mode od in console you can see chain of exceptions with failed connection and reason.

Note You need to log in before you can comment on or make changes to this bug.