Bug 1255553 - [Feature Request] Build Wireshark with lua support
[Feature Request] Build Wireshark with lua support
Status: CLOSED DUPLICATE of bug 1259623
Product: Fedora
Classification: Fedora
Component: wireshark (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Hatina
Fedora Extras Quality Assurance
https://ask.wireshark.org/questions/4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-20 19:18 EDT by Andrew Cook
Modified: 2016-12-07 10:26 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-21 09:11:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Disable bitop module (5.16 KB, patch)
2015-08-21 09:20 EDT, Andrew Cook
no flags Details | Diff

  None (edit)
Description Andrew Cook 2015-08-20 19:18:32 EDT
Description of problem:
No lua support in wireshark

This is useful for quickly writing dissectors

spec is already set up to build with lua, though currently disabled
Comment 1 Andrew Cook 2015-08-20 19:27:10 EDT
Apparently fails to build:

  CC       lua_bitop.lo
./lua_bitop.c: In function 'barg':
./lua_bitop.c:85:2: error: #error "Unknown number type, check LUA_NUMBER_* in luaconf.h"
 #error "Unknown number type, check LUA_NUMBER_* in luaconf.h"
  ^
./lua_bitop.c:61:10: warning: variable 'bn' set but not used [-Wunused-but-set-variable]
   BitNum bn;
          ^
Makefile:690: recipe for target 'lua_bitop.lo' failed
Comment 2 Andrew Cook 2015-08-20 21:10:23 EDT
Might outright require lua 5.2
Comment 3 Peter Lemenkov 2015-08-21 09:11:40 EDT
(In reply to Andrew Cook from comment #2)
> Might outright require lua 5.2

Andrew we can't do it for now. If you have a working patch which allows building against Lua 5.3.x that would be really helpful. You may want to check patch attached in Bug #1230286.

Feel free to reopen if find something.

*** This bug has been marked as a duplicate of bug 1230286 ***
Comment 4 Andrew Cook 2015-08-21 09:20:59 EDT
Created attachment 1065607 [details]
Disable bitop module

Got it to build by removing the bitop module, while fine for my use a proper solution would replace bitop.
5.3 adds bitwise operators which i assume are equivalent in all but syntax
Comment 5 Peter Lemenkov 2016-12-07 10:26:09 EST

*** This bug has been marked as a duplicate of bug 1259623 ***

Note You need to log in before you can comment on or make changes to this bug.