Bug 125559 - xpdf crashes while displaying PDF file
xpdf crashes while displaying PDF file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xpdf (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-08 14:32 EDT by Ralf Ertzinger
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-24 12:32:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xpdf backtrace (3.88 KB, text/plain)
2004-06-08 14:33 EDT, Ralf Ertzinger
no flags Details

  None (edit)
Description Ralf Ertzinger 2004-06-08 14:32:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
When loading the PDF file located at
http://www.karlsruhe.de/KVV/download/lnp/lnpnetz.pdf
xpdf crashes with a SIGSEGV during initial display of the file.

gpdf shows the file just fine.

Backtrace is attached.

Version-Release number of selected component (if applicable):
xpdf-3.00-3

How reproducible:
Always

Steps to Reproduce:
1. Download file above
2. display using xpdf
3.
    

Actual Results:  xpdf crashes

Expected Results:  Display of the file

Additional info:
Comment 1 Ralf Ertzinger 2004-06-08 14:33:17 EDT
Created attachment 100974 [details]
xpdf backtrace
Comment 2 Ngo Than 2004-06-24 12:17:22 EDT
it looks like the bug is in t1lib font rasterizer.
Comment 3 Ngo Than 2004-06-24 12:18:09 EDT
if you starts with xpdf -t1lib no, it should work
Comment 4 Ngo Than 2004-06-24 12:32:04 EDT
it's fixed in xpdf-3.00-5, which will be showed up in rawhide soon.

Note You need to log in before you can comment on or make changes to this bug.