Bug 1255660 - NetworkManager - routes issue [NEEDINFO]
NetworkManager - routes issue
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: NetworkManager (Show other bugs)
7.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Rashid Khan
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-21 05:29 EDT by mkubat
Modified: 2015-09-29 11:16 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-29 11:16:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rkhan: needinfo? (mkubat)


Attachments (Terms of Use)

  None (edit)
Description mkubat 2015-08-21 05:29:40 EDT
Description of problem:
NetworkManager is not setting up properly GW when you swap from DHCP to Manual and back to DHCP.

Version-Release number of selected component (if applicable): RHEL 7 and above
tested on version - NetworkManager-1.0.0-14.git20150121.b4ea599c.el7.x86_64

How reproducible:
Swap to manual settings in NM, set some network and swap back to DHCP, check routes.

Steps to Reproduce:
1.) connect on wire with DHCP settings -> up and running
2.) change network settings to manual and set i.e. 192.168.1.1,
255.255.255.0 and GW 192.168.1.254 and some DNS 192.168.1.254 -> up
and
running
3.) change manual settings to automatic, back to DHCP -> you get IP
address, DNS server but you still have GW 192.168.1.254
4.) manually: ip route add default via 10.33.1.254 -> up and running

Actual results:
not properly set GW after getting back to DHCP.

Expected results:
Properly set GW after getting back to DHCP.

Additional info:
You can fix it by setting the GW to 0.0.0.0 in manual and than change to DHCP.. that will give you a new GW.

Please open a bugzilla and add me as CC to this.

Thanks
Oliver
Comment 1 Vladimir Benes 2015-08-21 05:38:32 EDT
(In reply to mkubat from comment #0)
> Description of problem:
> NetworkManager is not setting up properly GW when you swap from DHCP to
> Manual and back to DHCP.
> 
> Version-Release number of selected component (if applicable): RHEL 7 and
> above
> tested on version - NetworkManager-1.0.0-14.git20150121.b4ea599c.el7.x86_64
> 
> How reproducible:
> Swap to manual settings in NM, set some network and swap back to DHCP, check
> routes.
> 
> Steps to Reproduce:
> 1.) connect on wire with DHCP settings -> up and running
> 2.) change network settings to manual and set i.e. 192.168.1.1,
> 255.255.255.0 and GW 192.168.1.254 and some DNS 192.168.1.254 -> up
> and
> running

how/where? in nmcli?

> 3.) change manual settings to automatic, back to DHCP -> you get IP
> address, DNS server but you still have GW 192.168.1.254

the same as above.. how did you change the settings?

> 4.) manually: ip route add default via 10.33.1.254 -> up and running
> 

thanks for info, what about flags?
Comment 3 Jirka Klimes 2015-08-21 07:07:36 EDT
I suppose the reporter used gnome-control center to edit the profile. I can't reproduce the problem with the latest RHEL 7.2 builds.
I'd say the bug is in gnome-control-center, but it is fixed now - bug 1039068.
Comment 4 mkubat 2015-08-21 08:04:43 EDT
additional info:

We've tested it with my colleague on RHEL 7.2 same package version.

zjurman|brb> mkubat|brb: btw my termin
<zjurman|brb> NetworkManager-1.0.0-14.git20150121.b4ea599c.el7.x86_64
* zjurman|brb is now known as zjurman
<zjurman> mkubat|brb: I was forced to downgrade it mannualy as no networks works after update
<zjurman> so I am expecting I have same bug with me, will test
* zjurman is back
<zjurman> mkubat|brb: no problem at all
* You are now known as mkubat
<mkubat> zjurman, nice so seems it's fixed in 7.2, in bug report is mentioned it's some gnome-control-center issue
<mkubat> nice
<zjurman> control-center-3.14.5-6.el7.x86_64

Jirka is right.

Fixed.
Comment 6 Jirka Klimes 2015-09-29 11:16:43 EDT
Closing the bug based on comment #4.
Should you still see an issue, feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.