Bug 125576 - ./configure reports an error but still succeeds
./configure reports an error but still succeeds
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-artwork (Show other bugs)
3.0
All Linux
medium Severity low
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-08 19:11 EDT by Patrick Devine
Modified: 2013-03-05 22:40 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:24:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Devine 2004-06-08 19:11:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
When attempting to build the package, during the./configure step it
will throw the error:

config.status: executing default-1 commands
config.status: executing default-2 commands
./config.status: line 1192: ./intltool-extract.in: No such file or
directory
mv: cannot stat `intltool-extract.out': No such file or directory
chmod: failed to get attributes of `intltool-extract': No such file or
directory
chmod: failed to get attributes of `intltool-extract': No such file or
directory
./config.status: line 1201: ./intltool-merge.in: No such file or directory
mv: cannot stat `intltool-merge.out': No such file or directory
chmod: failed to get attributes of `intltool-merge': No such file or
directory
chmod: failed to get attributes of `intltool-merge': No such file or
directory
./config.status: line 1210: ./intltool-update.in: No such file or
directory
mv: cannot stat `intltool-update.out': No such file or directory
chmod: failed to get attributes of `intltool-update': No such file or
directory
chmod: failed to get attributes of `intltool-update': No such file or
directory
config.status: executing default-3 commands

but then continues to build anyway.  In looking through the source,
it's choking on the line:

sed -e "s:@INTLTOOL_PERL@:${INTLTOOL_PERL}:;" <
${srcdir}/intltool-extract.in > intltool-extract.out

because intltool-extract.in doesn't exist.  I believe the RPM is being
built correctly despite the error (it spits one out), however I
haven't verified that it works yet.

Version-Release number of selected component (if applicable):
redhat-artwork-0.73.2-1E

How reproducible:
Always

Steps to Reproduce:
1. install the redhat-artwork-0.73.2-1E source rpm
2. extract the tar ball in the BUILD directory
3. run ./configure
    

Additional info:
Comment 1 RHEL Product and Program Management 2007-10-19 15:24:42 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.