Bug 1255773 - php-magickwand-1.0.9 and (missing) ImageMagick-6.7 dependency
php-magickwand-1.0.9 and (missing) ImageMagick-6.7 dependency
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: php (Show other bugs)
6.8
x86_64 Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Web Stack Team
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-21 09:57 EDT by fedora
Modified: 2015-09-10 04:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-10 01:59:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CentOS 0009205 None None None Never

  None (edit)
Description fedora 2015-08-21 09:57:01 EDT
Recent auto-updates with yum brought up the following unresolved dependency:

Error: Package: php-magickwand-1.0.9-1.el6.x86_64 (@epel)
   Requires: libMagickCore.so.2()(64bit)
   Removing: ImageMagick-6.5.4.7-7.el6_5.x86_64 (installed)
       libMagickCore.so.2()(64bit)
   Updated By: ImageMagick-6.7.2.7-2.el6.x86_64 (base)
       Not found

There is a ImageMagick-6.7, however installing it manually after removing 6.5
makes it impossible to install php-magickwand as it requires libMagickCore.so.2
and ImageMagick-6.7 provides libMagickCore.so.5.

Steps to Reproduce: 
1. Do a yum update on CentOS 6.7
2. Above error shows up
3. Manually remove: yum remove php-magickwand ImageMagick
4. yum update
5. yum install php-magickwand

Step 5 gives the error: libMagickCore.so.2 is required by php-magickwand, but
libMagickCore.so.5 installed already by ImageMagick-6.7.

Additional Information: 
Above error states "ImageMagick-6.7.2.7-2.el6.x86_64 (base) is Not found",
however after installing it manually, there is no more libMagickCore.so.2. So
please update php-magickwand to work with libMagickCore.so.5 instead of .2.
Comment 2 Remi Collet 2015-09-10 01:59:06 EDT
php-magicwand is not part of RHEL, so closing this one.

Please open a bug report for php-magickwand in EPEL.
Comment 3 fedora 2015-09-10 04:00:24 EDT
Unfortunately, I'm not permitted to change products for this bug.
Comment 4 Remi Collet 2015-09-10 04:02:34 EDT
(In reply to fedora from comment #3)
> Unfortunately, I'm not permitted to change products for this bug.

The reason why I have to close it and ask you to open a new one.
Comment 5 fedora 2015-09-10 04:04:33 EDT
Quite a work overhead regarding my very limited time, isn't it?

Note You need to log in before you can comment on or make changes to this bug.