This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 125580 - cdrecord: Cannot load media with this drive!
cdrecord: Cannot load media with this drive!
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cdrtools (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-08 21:45 EDT by Dave Maley
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-09 11:40:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Maley 2004-06-08 21:45:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
Unable to burn CD using cdrecord under FC2.  System is a Fujitsu
S-4572 laptop w/ a MATSHITA UJDA71 CD-R/DVD drive.  Getting the
following output/error:

[dave@maggie burn]$ cdrecord -v -dao -pad -eject *wav
Cdrecord-Clone 2.01a27-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004
J�rg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
<warly@mandrakesoft.com>.
Note: The author of cdrecord should not be bothered with problems in
this version.
TOC Type: 0 = CD-DA
cdrecord: Operation not permitted. WARNING: Cannot do mlockall(2).
cdrecord: WARNING: This causes a high risk for buffer underruns.
cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
cdrecord: Permission denied. WARNING: Cannot set priority using
setpriority().
cdrecord: WARNING: This causes a high risk for buffer underruns.
scsidev: 'ATAPI:0,1,0'
devname: 'ATAPI'
scsibus: 0 target: 1 lun: 0
Warning: Using ATA Packet interface.
Warning: The related libscg interface code is in pre alpha.
Warning: There may be fatal problems.
Using libscg version 'schily-0.8'.
Driveropts: 'burnfree'
SCSI buffer size: 64512
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 2
Capabilities   :
Vendor_info    : 'MATSHITA'
Identifikation : 'UJDA710         '
Revision       : '1.05'
Device seems to be: Generic mmc2 DVD-ROM.
cdrecord: Cannot load media with this drive!
cdrecord: Try to load media by hand.
cdrecord: Cannot load media.

Version-Release number of selected component (if applicable):
cdrecord-2.01-0.a27.4

How reproducible:
Always

Steps to Reproduce:
1. insert blank CD-R
2. issue command (cdrecord -v -dao -pad -eject *.wav)
3.
    

Actual Results:  receive above error

Expected Results:  successful burn

Additional info:

I've also tried adding hdb=ide-cd to my kernel command line to no avail.
Comment 1 Dave Maley 2004-06-08 21:47:24 EDT
appears to be a known issue - see:

   http://lists.debian.org/cdwrite/2004/05/msg00177.html

Any chance of getting a (test) package built w/ cdrtools-2.01a30-pre1?
Comment 2 Dave Maley 2004-06-09 11:32:14 EDT
just test w/ the 2.01a30-pre1 which was supposed to address this
problem, but it doesn't appear to work either:

[dave@maggie i686-linux-cc]$ ./cdrecord -v -dao -pad -eject
dev=ATAPI:0,1,0 /tmp/burn/*wav
Cdrecord-Clone 2.01a31 (i686-pc-linux-gnu) Copyright (C) 1995-2004
J�rg Schilling
TOC Type: 0 = CD-DA
./cdrecord: Operation not permitted. WARNING: Cannot do mlockall(2).
./cdrecord: WARNING: This causes a high risk for buffer underruns.
./cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
./cdrecord: Permission denied. WARNING: Cannot set priority using
setpriority()../cdrecord: WARNING: This causes a high risk for buffer
underruns.
scsidev: 'ATAPI:0,1,0'
devname: 'ATAPI'
scsibus: 0 target: 1 lun: 0
Warning: Using ATA Packet interface.
Warning: The related libscg interface code is in pre alpha.
Warning: There may be fatal problems.
Using libscg version 'schily-0.8'.
SCSI buffer size: 64512
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 2
Capabilities   :
Vendor_info    : 'MATSHITA'
Identifikation : 'UJDA710         '
Revision       : '1.05'
Device seems to be: Generic mmc2 DVD-ROM.
./cdrecord: Cannot load media with this drive!
./cdrecord: Try to load media by hand.
Current: 0x0000
Profile: 0x0010
Profile: 0x000A
Profile: 0x0009
Profile: 0x0008
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC-2 SWABAUDIO
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R
FIFO size      : 4194304 = 4096 KB
Track 01: audio   50 MB (04:59.25) no preemp
Track 02: audio   32 MB (03:15.05) no preemp
Track 03: audio   33 MB (03:18.16) no preemp
Track 04: audio   44 MB (04:26.70) no preemp
Track 05: audio   40 MB (04:03.12) no preemp
Track 06: audio   36 MB (03:35.45) no preemp
Track 07: audio   62 MB (06:14.25) no preemp
Track 08: audio   43 MB (04:19.13) no preemp
Track 09: audio   47 MB (04:43.48) no preemp
Track 10: audio   46 MB (04:37.04) no preemp
Track 11: audio  143 MB (14:15.89) no preemp
Track 12: audio  112 MB (11:10.28) no preemp
Total size:      696 MB (68:57.82) = 310337 sectors
Lout start:      696 MB (68:59/62) = 310337 sectors
./cdrecord: Cannot load media with this drive!
./cdrecord: Try to load media by hand.
./cdrecord: Cannot load media.


--> I will report this to the upstream maintainer ...
Comment 3 Dave Maley 2004-06-09 11:40:48 EDT
doh!  I just tested again using different blank media and
cdrecord-2.01-0.a27.4 seems to be working fine now.  Guess this drive
just doesn't like the el-cheapo media ... sorry.

~Dave

Note You need to log in before you can comment on or make changes to this bug.