Bug 1255843 - KDE5 file open dialogue freezes
KDE5 file open dialogue freezes
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: plasma-desktop (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: KDE SIG
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-21 12:33 EDT by Ivan Romanov
Modified: 2015-10-20 09:49 EDT (History)
8 users (show)

See Also:
Fixed In Version: kf5-frameworkintegration-5.15.0-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-20 09:49:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Testcase to reproduce error (1.28 KB, application/x-gzip)
2015-08-21 12:33 EDT, Ivan Romanov
no flags Details
Full gdb backtrace (7.20 KB, text/plain)
2015-08-21 12:45 EDT, Ivan Romanov
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 350758 None None None Never

  None (edit)
Description Ivan Romanov 2015-08-21 12:33:03 EDT
Created attachment 1065639 [details]
Testcase to reproduce error

Description of problem:
Qt5 application often freezes when calling Open File dialog. I think it is a problem with KDE5.

Version-Release number of selected component (if applicable):
Fedora 22
plasma-desktop-5.3.2-3.fc22.x86_64

How reproducible:
Often

Steps to Reproduce:
1. compile attached testcase with Qt5
2. run
3. click button

Actual results:
application freezes

Expected results:
opened Open file dialog
Comment 1 Ivan Romanov 2015-08-21 12:39:49 EDT
backtrace 

#0  0x000000350f4f72fd in poll () at /lib64/libc.so.6
#1  0x0000003511449dbc in g_main_context_iterate (priority=2147483647, n_fds=11, fds=0x146f690, timeout=<optimized out>, context=0x7fffec0016f0) at gmain.c:4103
#2  0x0000003511449dbc in g_main_context_iterate (context=context@entry=0x7fffec0016f0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3803
#3  0x0000003511449ecc in g_main_context_iteration (context=0x7fffec0016f0, may_block=1) at gmain.c:3869
#4  0x00000030e26d6b6f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x686530, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#5  0x00000030e267ceba in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7fffffffc860, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00000030e4346c5d in QDialog::exec() (this=0x138cbe0) at dialogs/qdialog.cpp:541
#7  0x00007ffff03e849f in KDEPlatformFileDialogHelper::exec() () at /usr/lib64/qt5/plugins/platformthemes/KDEPlatformTheme.so
#8  0x00000030e4346b1a in QDialog::exec() (this=this@entry=0x7fffffffc9f0) at dialogs/qdialog.cpp:537
#9  0x00000030e43581f5 in QFileDialog::getOpenFileUrl(QWidget*, QString const&, QUrl const&, QString const&, QString*, QFlags<QFileDialog::Option>, QStringList const&) (parent=parent@entry=0x7fffffffd990, caption=..., dir=..., filter=..., selectedFilter=selectedFilter@entry=0x0, options=..., supportedSchemes=...) at dialogs/qfiledialog.cpp:2138
#10 0x00000030e43582c2 in QFileDialog::getOpenFileName(QWidget*, QString const&, QString const&, QString const&, QString*, QFlags<QFileDialog::Option>) (parent=parent@entry=0x7fffffffd990, caption=..., dir=..., filter=..., selectedFilter=selectedFilter@entry=0x0, options=...) at dialogs/qfiledialog.cpp:2085
#11 0x00000000004033c1 in Dialog::openFile() (this=0x7fffffffd990) at dialog.cpp:23
Comment 2 Ivan Romanov 2015-08-21 12:45:15 EDT
Created attachment 1065645 [details]
Full gdb backtrace
Comment 3 Daniel Vrátil 2015-08-21 19:46:08 EDT
I can confirm, I've seen the same problem couple times myself. Apparently hitting escape still closes the dialog (in most cases) and you can at least save your current work.
Comment 4 Francois Nitenberg 2015-10-20 09:40:37 EDT
I confirm this issue.
The 'Open file' dialog seems to be instantiated (pressing escape recovers the main app) but it's not rendered.
Comment 5 Rex Dieter 2015-10-20 09:49:44 EDT
This should be fixed with kf5-frameworkintegration-5.15.0 currently in -testing,
https://bodhi.fedoraproject.org/updates/FEDORA-2015-176062173b

Note You need to log in before you can comment on or make changes to this bug.