Bug 1255926 - [abrt] qt-creator: Breeze::Helper::frameOutlineColor(QPalette const&, bool, bool, double, Breeze::AnimationMode) const(): qtcreator killed by SIGABRT
[abrt] qt-creator: Breeze::Helper::frameOutlineColor(QPalette const&, bool, b...
Status: CLOSED DUPLICATE of bug 1247967
Product: Fedora
Classification: Fedora
Component: qt-creator (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Itamar Reis Peixoto
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:65e37693b0e053b0099304ea05f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-21 18:11 EDT by Alex
Modified: 2015-08-21 19:06 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-21 19:06:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (84.70 KB, text/plain)
2015-08-21 18:11 EDT, Alex
no flags Details
File: cgroup (190 bytes, text/plain)
2015-08-21 18:11 EDT, Alex
no flags Details
File: core_backtrace (23.06 KB, text/plain)
2015-08-21 18:11 EDT, Alex
no flags Details
File: dso_list (27.20 KB, text/plain)
2015-08-21 18:11 EDT, Alex
no flags Details
File: environ (1.63 KB, text/plain)
2015-08-21 18:11 EDT, Alex
no flags Details
File: limits (1.29 KB, text/plain)
2015-08-21 18:11 EDT, Alex
no flags Details
File: maps (131.73 KB, text/plain)
2015-08-21 18:11 EDT, Alex
no flags Details
File: mountinfo (3.38 KB, text/plain)
2015-08-21 18:11 EDT, Alex
no flags Details
File: namespaces (85 bytes, text/plain)
2015-08-21 18:11 EDT, Alex
no flags Details
File: open_fds (13.75 KB, text/plain)
2015-08-21 18:11 EDT, Alex
no flags Details
File: proc_pid_status (1008 bytes, text/plain)
2015-08-21 18:11 EDT, Alex
no flags Details
File: var_log_messages (317 bytes, text/plain)
2015-08-21 18:11 EDT, Alex
no flags Details

  None (edit)
Description Alex 2015-08-21 18:11:31 EDT
Description of problem:
First I open Qt Creator and access Tools-> Options and make any modification. After that push the button Apply or Ok and the program is crashing. 

Version-Release number of selected component:
qt-creator-3.4.2-1.fc22

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /bin/qtcreator
crash_function: Breeze::Helper::frameOutlineColor(QPalette const&, bool, bool, double, Breeze::AnimationMode) const
executable:     /usr/bin/qtcreator
global_pid:     3293
kernel:         4.1.5-200.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #6 Breeze::Helper::frameOutlineColor(QPalette const&, bool, bool, double, Breeze::AnimationMode) const at ../../kstyle/breezehelper.h:78
 #8 Breeze::FrameShadow::paintEvent(QPaintEvent*) at ../../kstyle/breezeframeshadow.cpp:340
 #9 QWidget::event(QEvent*) at kernel/qwidget.cpp:9034
 #10 QApplicationPrivate::notify_helper(QObject*, QEvent*) at kernel/qapplication.cpp:3717
 #11 QApplication::notify(QObject*, QEvent*) at kernel/qapplication.cpp:3500
 #12 QCoreApplication::notifyInternal(QObject*, QEvent*) at kernel/qcoreapplication.cpp:965
 #13 QWidgetPrivate::sendPaintEvent(QRegion const&) at ../../src/corelib/kernel/qcoreapplication.h:227
 #15 QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) at kernel/qwidget.cpp:5559
 #16 QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) at kernel/qwidget.cpp:5754
 #19 QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) at kernel/qwidget.cpp:5611
Comment 1 Alex 2015-08-21 18:11:36 EDT
Created attachment 1065750 [details]
File: backtrace
Comment 2 Alex 2015-08-21 18:11:37 EDT
Created attachment 1065751 [details]
File: cgroup
Comment 3 Alex 2015-08-21 18:11:39 EDT
Created attachment 1065752 [details]
File: core_backtrace
Comment 4 Alex 2015-08-21 18:11:40 EDT
Created attachment 1065753 [details]
File: dso_list
Comment 5 Alex 2015-08-21 18:11:42 EDT
Created attachment 1065754 [details]
File: environ
Comment 6 Alex 2015-08-21 18:11:43 EDT
Created attachment 1065755 [details]
File: limits
Comment 7 Alex 2015-08-21 18:11:45 EDT
Created attachment 1065756 [details]
File: maps
Comment 8 Alex 2015-08-21 18:11:47 EDT
Created attachment 1065757 [details]
File: mountinfo
Comment 9 Alex 2015-08-21 18:11:48 EDT
Created attachment 1065758 [details]
File: namespaces
Comment 10 Alex 2015-08-21 18:11:49 EDT
Created attachment 1065759 [details]
File: open_fds
Comment 11 Alex 2015-08-21 18:11:51 EDT
Created attachment 1065760 [details]
File: proc_pid_status
Comment 12 Alex 2015-08-21 18:11:52 EDT
Created attachment 1065761 [details]
File: var_log_messages
Comment 13 Sandro Mani 2015-08-21 19:06:30 EDT

*** This bug has been marked as a duplicate of bug 1247967 ***

Note You need to log in before you can comment on or make changes to this bug.