Bug 1255955 - Cannot choose application by path in application chooser dialog
Cannot choose application by path in application chooser dialog
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gtk3 (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-22 05:54 EDT by Thomas Meyer
Modified: 2017-01-30 05:00 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-17 20:24:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Meyer 2015-08-22 05:54:37 EDT
Description of problem:
I try to open a file called launch.rdp in firefox. Firefox show the file open dialog for type "rdp file".

I choose "open with" and then I'm not able to give the path of the application to open the file with. I wanted to open the file with the program "/usr/bin/xfreerdp", but there seems to be now way to specify the path of a locally installed application. Instead I only have to options to
"show all applications" or to "search a new application".

Please fix this horrific usability  error!

Version-Release number of selected component (if applicable):
firefox 39.0.3
Comment 1 Jan Horak 2015-08-24 03:04:44 EDT
This is a dialog from GTK3 toolkit. Reassigning component. See: https://developer.gnome.org/gtk3/stable/GtkAppChooserDialog.html
Maybe there's a way to show "Browse" button, but from documentation I see none.
Comment 2 Matthias Clasen 2015-12-17 20:24:11 EST
If you want to open a file from /usr/bin, use a filechooser. The appchooser is about choosing applications that are represented by desktop files.
Comment 3 Jan Horak 2015-12-18 04:28:44 EST
Okay, so we should use filepicker, not the appchooser in Firefox?
Comment 4 Matthias Clasen 2015-12-21 11:48:56 EST
No, you shouldn't. Choosing a binary in /usr/bin is not a great user experience.
Comment 5 Doncho N. Gunchev 2017-01-30 05:00:00 EST
Choosing a binary like ~/bin/myscript.sh should not involve managing mime databases :(

Note You need to log in before you can comment on or make changes to this bug.