Bug 125596 - Read-only file system error at startup
Summary: Read-only file system error at startup
Status: CLOSED DUPLICATE of bug 125597
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 2
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-09 08:15 UTC by albert vilella
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:04:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description albert vilella 2004-06-09 08:15:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
I get an error just after "Checking for hardware" at startup:

Updating /etc/fstab Unable to open /etc/fstab for writing: Read-only
file system
                  [FAILED]
touch: cannot touch `/var/lock/subsys/kudzu': Read-only file system
Starting cpuspeed:     [OK]
touch: cannot touch `/var/lock/subsys/cpuspeed': Read-only file system
Setting network parameters:    [OK]
Bringing up loopback interface:     [OK]
Bring up interface eth0:    [OK]
touch: cannot touch `/var/lock/subsys/network': Read-only file system
Starting system logger:

Here gets clogged for 3-5 minutes

Then keeps going, with more errors:
touch: cannot touch `/var/lock/subsys/xxxxxxx': Read-only file system

Then the X is not able to start...

If I login as root on console mode and run "df" the partitions seem to
be lost:

Filesystem      1K-blocks      Used    Available    Use%   Mounted on
/dev/hda2        12096756   6616716      4865556     58%   /
/dev/hda1        12096756   6616716      4865556     58%   /boot
/dev/hda5        12096756   6616716      4865556     58%   /data1
/dev/hda7        12096756   6616716      4865556     58%   /data2
none        12096756   6616716      4865556     58%   /dev/shm
/dev/hda6        12096756   6616716      4865556     58%   /home

I did a fresh install of FC2 yesterday checking the size of the hard
drive and using (maybe cylinders and tables are the other way around):

linux hda:4864,255,63

Any hint?


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Reboot
2. Wait 5 minutes until complete startup
3. See errors
    

Actual Results:  See lots of errors regarding read-only file system
and X not starting up

Expected Results:  Normal bootup, as it was yesterday for a couple or
3 times

Additional info:

Yesterday I switched off some services in system-config-services,
mainly NFS-related, special fonts, bluetooth and pcmcia interfaces.
Maybe I switched off one of them that is needed, but I find it strange
as the error happens just after "Checking for new hardware"

Comment 1 albert vilella 2004-06-09 08:46:14 UTC

*** This bug has been marked as a duplicate of 125597 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:04:00 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.